• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 351
  • Last Modified:

Faster RDP access

Hi there,

I would like an expert help in my situation . I have a windows 7 professional workstation in a lab and it has all the applications installed for the lab. I sit on my desk with windows XP SP3 laptop. Sometimes I like to RDP to the Windows 7 workstation and check results. I have seen that when I do mstsc to the windows 7 computer the RDP client takes time to prompt me to the login window. We are on the same network segment and I am not sure what is causing this delay. Is there a way I can speed it up a little? Do I have to do any thing on the windows 7 or windows XP that I am using.

Many thanks
0
Habib Zakaria
Asked:
Habib Zakaria
  • 3
  • 2
  • 2
  • +1
2 Solutions
 
Aaron TomoskySD-WAN SimplifiedCommented:
Do you use the computername or ip? Are they in the same workgroup? What is the ping time?
0
 
Habib ZakariaNetwork Solutions ArchitectAuthor Commented:
I use the hostname, both are in the same domain. I did not check the ping time sorry?
Another question I have is the windows 7 has something know as tuneing on the RDP session could that be the cause. I do RDP to other workstions and it is faster but those are XP client. This is the first windows 7 client.
0
 
Aaron TomoskySD-WAN SimplifiedCommented:
Try the ip, if it's faster then its a dns/nslookup issue. If it's the same, it may be searching for a certificate (win7 has a newer more secure mstsc than xp). Let's start with this test before we dig any deeper.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
WiReDWolfCommented:
I have found that windows 7 has enabled certain networking features that actually slow it down quite a lot.  Try editing the configuration of the windows 7 driver for the nic and disable anything that says "offload".  Also disable power management for the nic which is in the same screen on the last tab.
0
 
UnicornBoyCommented:
It might be your network passive (cable/wireless) or active (switches, NICs, etc.) latency problem.
if everything else is okay and only this RDP is slow.
the only thing that might slow it is the low bandwidth of your local network.

a suggestion would be using lower color setting to speed the connection up. you can specify color mode of 15bit in the display tab, or even lower.
lower modes was previously supported in the GUI of the mstsc of XP, but in windows 7 you have to save rdp settings to a file (*.rdp) and open it by a text editor such as notepad. then goto the lne with "session bpp:i:15" and change 15 to the minimum number of 8.
0
 
Habib ZakariaNetwork Solutions ArchitectAuthor Commented:
Thanks guys.  I did a NLB on the 2 nics on the workstation and the RDP started to be faster. My Session bpp:i:32 is the same..

I will give you both half points for your comments.

Thanks,
0
 
Habib ZakariaNetwork Solutions ArchitectAuthor Commented:
Good comments.
0
 
UnicornBoyCommented:
thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now