• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 349
  • Last Modified:

Adding SSL to an external address for our intranet

We have SP 2010 foundation and want to share it with a few people outside our network. If you are on our netowrk you can just go to http://sharepoint. We have SSO enabled so you have to do nothing more. I am trying to get https://sharepoint.ourdomain.com to work. I am missing something. I went into central admin and added that URL to the custom field, configured our internal DNS correctly, and I then went to IIS and bound the cert to 443 on the default site. There are other sites in there but this vm runs only SP web services and such the db is on another box, though I am not sure default is the correct site. When you go to https://sharepoint.ourdomain.com it prompts for your credentials and just continues to do so. You never go anywhere. What am I missing?
0
nkrueger84
Asked:
nkrueger84
  • 4
  • 3
1 Solution
 
Lance_PCommented:
Have you tried publishing with anonymous access? I would assume that this would need to be on http and not https?
0
 
jessc7Commented:
Instead of creating an AAM for the SSL enabled site, try extending the web application. Make sure to check the SSL option for the web app settings.

http://technet.microsoft.com/en-us/library/cc288162.aspx
0
 
jessc7Commented:
Once you have extended the web app, a new site will be created in IIS. Make sure to assign the certificate to the new site.

As for IE, you will need to add the site to the Trusted Sites
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
nkrueger84Author Commented:
Isn't that spiffy. I am a SharePoint novice at best. I will give it a whirl tomorrow. Thanks!
0
 
nkrueger84Author Commented:
It is working. I set the zone as Internet. I have read a bit and I am still not sure what the zones mean and how they matter. The internal zones are set to default.
0
 
nkrueger84Author Commented:
Sorry, another question. "Some content is not being delivered securely" is popping up. Looks like the pictures are not encrypted because if you answer no the the pop up they do not load. What is the best way to handle this? The secure external site is not used by a huge number of people (10 in all so 1 or 2 at a time) so I think that encrypting the pics would not be a huge issue (not that I know where that setting is).
0
 
jessc7Commented:
My guess is that the pictures were added using an absolute URL reference. Something like:

http://server/assets/image.jpg

You would need to make the references relative. So taking the above example, change to:

/assets/image.jpg

This will allow them to be sources as either http or https.
0
 
nkrueger84Author Commented:
Thank you very much!
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now