Need help recovering Windows 7 software RAID10

Posted on 2011-09-18
Last Modified: 2013-11-14
I have four WD Caviar Black 750GB drives in RAID10 (software RAID in Windows 7 Pro) for 1.5TB of storage for my BeyondTV DVR.  It worked great for many months, but we shut it down to move it temporarily, and when I turned it back on a few days later the RAID array is gone.

The OS is on a separate drive, so the PC works fine, but my video files are inaccessible.  

Windows still sees the four drives, but they are reported in Disk Management as follows:

Disk 0 - Basic - Online - (F:) 698.64 GB RAW - Healthy (Primary Partition)
Disk 1 - Basic - Online  - (no drive letter) 698.64 GB - Unallocated
Disk 2 - Basic - Online - (no drive letter) 698.64 GB - (no status listed)
Disk 3 - Unknown - Not Initialized  - (no drive letter) 698.64 GB - Unallocated

I looked at the drives with TestDisk, specifying an Intel/PC partition type:

Disk 0:
Disk /dev/sda - 750 GB / 698 GiB - CHS 91201 255 63
Current partition structure:
     Partition                  Start        End    Size in sectors

Invalid NTFS or EXFAT boot
 1 P HPFS - NTFS              0  32 33 182401 198  5 2930282496
 1 P HPFS - NTFS              0  32 33 182401 198  5 2930282496
No partition is bootable

Disk 1:
Disk /dev/sdb - 750 GB / 698 GiB - CHS 91202 255 63
Current partition structure:
     Partition                  Start        End    Size in sectors

No partition is bootable

Disk 2:
Disk /dev/sdc - 750 GB / 698 GiB - CHS 91201 255 63
Current partition structure:
     Partition                  Start        End    Size in sectors

Invalid NTFS or EXFAT boot
 1 P HPFS - NTFS              0  32 33 182401 198  5 2930282496
 1 P HPFS - NTFS              0  32 33 182401 198  5 2930282496
No partition is bootable

Disk 3:
Disk /dev/sdd - 750 GB / 698 GiB - CHS 91201 255 63
Current partition structure:
     Partition                  Start        End    Size in sectors

Partition sector doesn't have the endmark 0xAA55

I don't have any reason to suspect multiple drive failures or a virus.  It's possible Windows didn't get shut down properly (somebody else powered it off before we moved it).  So I'm hoping this is a relatively simple corruption of the RAID signature.

Unfortunately I don't have a system state backup, but the C: drive is Ok and the computer is bootable, so if Windows stores the RAID config info somewhere other than on the RAID drives, I might be able to get my hands on it.

Can anyone tell me where to go from here?  I don't want to just "try things" for fear of making it worse.


Question by:trusnock
LVL 18

Accepted Solution

Rartemass earned 500 total points
ID: 36558247
You can run this as a trial version:

It will tell you if the software can restore the RAID array.
If it can you'll need to obtain the full version to actually recover it.
Should be a good thing to try as testing shouldn't destroy anything.

Expert Comment

ID: 36559949
Perhaps it is as simple as using system restore to select a restore point for windows OS prior to the move.  You did say it was windows software raid, so this should put windows back in that correct state to see the raided drive. It will do nothing to the other drives, but will tell Windows how to treat the drives - as an array.

Author Comment

ID: 36560556
Boilermaker85: For some reason, the only restore point is from 3 days ago (even when I click "show more restore points"), which is three days after I suspect the array went away.  I'm not SURE when the array went away, so I tried it anyway, but it didn't help.

Rartemass: According to their website, Runtime's Raid Recovery only supports RAID0 and RAID5, and I have a RAID10.  Since RAID10 is actually a mirror of two stripe sets, I'm trying it now on just the first two drives as RAID0.  So far it looks very promising, showing me all the files from the array.  I'll let you know after I spend $99 whether it worked.
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

LVL 18

Expert Comment

ID: 36563868
Raid 10 (or raid 1+0) is a raid 0 that is mirrored (raid 1).
So something that can recover raid 0 will help with raid10.
Glad its looking promising for you.

Expert Comment

ID: 36578140
How you build the RAID10?  By from the Intel chipset or other software or hardware?
This is very important,  because all Raid recovey need to know the exact build method. This is the key point to recover your raid. Software tool to recover the raid only work on  the raid which using the same method built.  
By the way, system restore cannot save the disk problem.


Author Closing Comment

ID: 36599939
Runtime software's "RAID Recovery for Windows" found the files and let me save them successfully to a USB drive.

Although my array was a RAID10 and the software only supports RAID5 and RAID0, I was able to use the RAID0 option (since a RAID10 is really a RAID1 array made of two RAID0 arrays), and simply point it at the first two drives.

I was hoping for something that could actually REPAIR the array and make it usable again, but this is the next best thing and I got all of my files back.

Thanks for your help!

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
Employees depend heavily on their PCs, and new threats like ransomware make it even more critical to protect their important data.
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question