Solved

Bandwidth Reservation on Cisco Routers

Posted on 2011-09-18
21
875 Views
Last Modified: 2012-05-12
I have 2 sites connected via Mpls circuit.It is of 1 Mbps capacity.
There is 1 Cisco router at each location.
I want to reserve bandwith of 256 Kbps for the voice traffic so that at any point of time voice traffic gets 256Kbps bandwidth. If the remaining available bandwidth is available it can use for the voice traffic.
Let me know what configurations i need to configure in the cisco routers at both the location.
0
Comment
Question by:SrikantRajeev
  • 11
  • 5
  • 5
21 Comments
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
class match-any voicetraffic
   match protocol rtp audio
   match protocol rtcp
   match access-group 111

ip access-list extended 111
permit ip x.x.x.x 0.0.0.255 any
 
(x.x.x.x denotes subnet voice traffic is coming from provided that its separate from data)


policy-map voice
class voicetraffic
bandwidth 256000
class class-default
fair-queue

interface x/x  (router outside interface)
service-policy output voice
max-reserved-bandwidth 100


Apply this to both routers. Let me know.



0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
2500 people in one building. Get at least a DS3, but I would recommend an OC3.
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Disregard above comment. Wrong thread. First comment is valid.
0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
I would like to understand what the below command means.
max-reserved-bandwidth 100

Also let me know when there is no voice traffic can the reset of the data traffic will be able to use the entire 1Mbps link which includes the 256Kbps reserved for voice.

Also let me know if my voice traffic exceeds 256 Kbps can it use the available bandwidth of the remaining 1 Mbps links.

0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
One more query since max-reserved-bandwidth 100 is there is it still required to the fair-queue command
0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
class match-any VoiceTraffic
   match protocol rtp audio
   match protocol rtcp
   match access-group 111

ip access-list extended 111
permit ip any any
 
policy-map voice
class VoiceTraffic
bandwidth percent 20
class class-default


interface x/x  (router outside interface)
no fair-quque
service-policy output voice
max-reserved-bandwidth 100

 Let me know if the above commands willl be fine.
Also I dont want that voice traffic is restricted to only 256 Kbps it should use the available bandwidth any time. This also applies the same to the data traffic.
0
 
LVL 17

Expert Comment

by:MAG03
Comment Utility
the bandwidth percent will work also, guarentee 20 percent to VoiceTraffic. Depending on your connection speed this may or may not be close to 256Kbps. I would go with soulja's suggestion of using bandwidth 256000 instead.

You could also instead of matching rtp and rtcp in the class map, match dscp ef (which is the default dscp marking for voip traffic).
0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
thanks
the reason why i am not using DSCP  & Ef is because my switches behind the routers are not QOS enabled. There will be chances that the QOS will be dropped at the switch level before it reaches my router.
But can you also answer my another query which i asked. I am repeating the same,

Also I dont want that voice traffic is restricted to only 256 Kbps it should use the available bandwidth any time. This also applies the same to the data traffic.
0
 
LVL 17

Expert Comment

by:MAG03
Comment Utility
the bandwidth 256 and bandwidth percent 20 provide the same functionality but in different ways. they both guarantee a set amount of bandwidth and they do allow use of more bandwidth if it is available.

Basically what happens is that when you issue the bandwidth percent 20 you are reserving 20% for class VoiceTraffic the other 80 percent will be allocated to the class-default. Now if class default uses all 80% then VoiceTraffic will not be able to use any excess bandwidth. However, if class-default only uses an aditional 20% then class VoiceTraffic has 60% of excess bandwidth that it is able to use.
0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
thanks
it is applicable in reverse order also.
For ex there is no voice traffic for long period of time. can the default class use all the bandwidth available during that point of time
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 17

Expert Comment

by:MAG03
Comment Utility
The command is only used when there is congestion on the interface. Basically what the bandwidth percent command is telling the router is that, when there is congestion guarantee 256Kbps for VoiceTraffic. If there is no congestion all traffic has equal access to the bandwidth.
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Thanks MAG03 for breaking it down for the author. I concur.

 The reason I told you to use bandwidth is because it will allow you do use more than the set amount if it is available, in addition to guaranteeing the 256k. If you use priority it will cap it at 256k.

Yes, there are many match options as MAG03 stated matching the dscp field. You can add that to the list in the class if you want. The great thing about match-any is that only one clause is needed to match against in the list under the class you create.
0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
I have configured it.
Below is the output of it.

Router 1
--------

Interface Serial1/0 queueing strategy: fair
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 52725
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/52725 (size/max total/threshold/drops)
     Conversations  0/3/256 (active/max active/max total)
     Reserved Conversations 1/1 (allocated/max allocated)
     Available Bandwidth 792 kilobits/sec


Router 2
--------

Interface Serial0/1 queueing strategy: fair
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 57
  Queueing strategy: Class-based queueing
  Output queue: 0/1000/64/57 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 1/1 (allocated/max allocated)
     Available Bandwidth 792 kilobits/sec

Could you please let me know if the configurations are right from the above output ?
the queueing strategy is differnet from both the routers.
I feel something is wrong
0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
I have the following commands on the router.

interface Serial1/0
 description " Router 1"
 bandwidth 1048
 ip address 1.1.1.2 255.255.255.255
 ip accounting output-packets
 ip route-cache flow
 load-interval 30
 max-reserved-bandwidth 100
 service-policy output voice

!
interface Serial0/1
 description " Router 2 "
 bandwidth 1048
 ip address 1.1.1.1 255.255.255.255
 no cdp enable
 max-reserved-bandwidth 100
 service-policy output voice


class-map match-any VoiceTraffic
  match protocol rtp
  match access-group 150
!
!
policy-map voice
  class VoiceTraffic
   bandwidth 256
  class class-default
   fair-queue
!
access-list 150 permit ip any any

Even after implementing the above still i face the problem with voice.
Since i have ip any any in the  ACL is the bandwidth settings not getting effected.
Let me know what i have done wrong with the configuration

0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
can some one help me regarding the above
0
 
LVL 17

Expert Comment

by:MAG03
Comment Utility
First off I would change the access list to only include the IP addresses of the VOIP phones. right now you are granting the same bandwidth to all traffic.

You could also just remove the ACL and just match rtp. However I would not suggest that.  I would instead match the IP addresses of the VOIP phones in ACL 150 and then use match all in the access list.

access-list extended 150 permit ip 10.1.1.0 0.0.0.255 any

class-map match-all VoiceTraffic
  match protocol rtp
  match access-group 150
0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
Thanks
The problem i have is in my network both Voice & Data are in same IP range.
So in this case i will use only RTP.
Should i use consider applying the ACL for all UDP packet. Any trafffic mathicng the UDP will be applied the policy.

One more question in the above mail.
the queueing strategy is differnet from both the routers. Please see the output above
0
 
LVL 17

Expert Comment

by:MAG03
Comment Utility
hmmm, do you have any other services running over the serial link? such as DHCP? The reason I ask is that not only VOIP uses UDP.

You could match UDP but then you could be granting the same bandwidth to many other traffic types that should not be within the traffic that is to be guaranteed that bandwidth. You just need to decide if there is any UDP traffic flowing over the link and if it would be ok for that traffic to also be included under the applied policy.

I would first test with RTP/RTCP and then perhaps move to UDP later if it isn't performing as expected. Or you can try both to see if there is any difference in performance.

One more question in the above mail.
the queueing strategy is differnet from both the routers. Please see the output above -------->  Well, first off you are using a bad subnet mask, unless that is a typing error. if you want to use that subnetmask you should use the ip unnumbered command.

They should both be showing class-based queueing, could be a misconfiguration. Could you post the running config for the interfaces and policy map for Router1. also issue the show policy-map voice on both Router 1 and 2, and post it here please.
0
 
LVL 1

Author Comment

by:SrikantRajeev
Comment Utility
At present i dont have the complete running conf. I have the interface conf & the policy map config for both the routers. I have pasted the same below. Hope it helps.

Router -1
---------


interface Serial1/0
 description " Router 1"
 bandwidth 1048
 ip address 1.1.1.2 255.255.255.0
 ip accounting output-packets
 ip route-cache flow
 load-interval 30
 max-reserved-bandwidth 100
 service-policy output voice

!

class-map match-any VoiceTraffic
  match protocol rtp
  match access-group 150
!
!
policy-map voice
  class VoiceTraffic
   bandwidth 256
  class class-default
   fair-queue
!
!
access-list 150 permit ip any any




Router -2
---------


interface Serial0/1
 description " Router 2 "
 bandwidth 1048
 ip address 1.1.1.1 255.255.255.0
 no cdp enable
 max-reserved-bandwidth 100
 service-policy output voice

!
class-map match-any VoiceTraffic
 match protocol rtp
 match protocol rtcp
 match access-group 150
!
!
policy-map voice
 class VoiceTraffic
  bandwidth 256
 class class-default
  fair-queue
!
0
 
LVL 26

Accepted Solution

by:
Soulja earned 500 total points
Comment Utility
Based on your configs above there is no reason they both shouldn't be using CBWFQ. The bandwidth command alone changes the queuing to class based.
0
 
LVL 1

Author Closing Comment

by:SrikantRajeev
Comment Utility
Thanks
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now