Solved

Cisco 877W and DynDNS

Posted on 2011-09-19
5
692 Views
Last Modified: 2012-06-27
ISP gives dynamical IP.  I use dyndns clients on NAS (name1.dyndns.org) and on local PC (name2.dyndns.org). But I'd like to use builtin dyndns feature in IOS Cisco 877W instead.

Config as below:
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash c870-advipservicesk9-mz.150-1.M7.bin
boot-end-marker
!
logging buffered 51200 informational
!
no aaa new-model
!
!
!
clock timezone MSK 3
clock summer-time MSK recurring last Sun Mar 2:00 last Sun Oct 3:00
!
crypto pki trustpoint tti
 revocation-check crl
 rsakeypair tti
!
crypto pki trustpoint TP-self-signed-<skip>
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-<skip>
 revocation-check none
 rsakeypair TP-self-signed-<skip>
!
!
crypto pki certificate chain tti
crypto pki certificate chain TP-self-signed-<skip>
 certificate self-signed 01
<skip>
        quit
dot11 syslog
!
dot11 ssid 877W
 authentication open
 authentication key-management wpa
 guest-mode
 wpa-psk ascii 7 <skip>
!
ip source-route
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.4
ip dhcp excluded-address 192.168.1.5
ip dhcp excluded-address 192.168.1.6
ip dhcp excluded-address 192.168.1.7
ip dhcp excluded-address 192.168.1.8
ip dhcp excluded-address 192.168.1.9
ip dhcp excluded-address 192.168.1.63
ip dhcp excluded-address 192.168.1.100
!
ip dhcp pool 877W
   network 192.168.1.0 255.255.255.0
   dns-server 156.154.70.22 156.154.71.22
   default-router 192.168.1.1
!
!
ip cef
ip domain name mtu.ru
ip name-server 156.154.70.22
ip name-server 156.154.71.22
ip inspect name DEFAULT100 cuseeme
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 h323
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 netshow
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 esmtp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
ip inspect name DEFAULT100 tcp router-traffic
ip inspect name DEFAULT100 udp router-traffic
ip inspect name DEFAULT100 icmp router-traffic
!
no ip igmp snooping
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username Mike privilege 15 secret 5 <skip>
!
!
!
!
!
!
bridge irb
!
!
!
interface ATM0
 description WAN
 no ip address
 no atm ilmi-keepalive
 !
!
interface ATM0.1 point-to-point
 description Stream Internet
 pvc 1/50
  pppoe-client dial-pool-number 1
 !
!
interface ATM0.2 point-to-point
 description VoD
 bridge-group 2
 bridge-group 2 spanning-disabled
 pvc 1/91
  encapsulation aal5snap
 !
!
interface ATM0.3 point-to-point
 description TV
 bridge-group 2
 bridge-group 2 spanning-disabled
 pvc 1/92
  encapsulation aal5snap
 !
!
interface FastEthernet0
 description 2Switch
 spanning-tree portfast
 !
!
interface FastEthernet1
 description Amino
 switchport access vlan 2
 no keepalive
 spanning-tree portfast
 !
!
interface FastEthernet2
 description 2MikePC
 switchport access vlan 2
 spanning-tree portfast
 !
!
interface FastEthernet3
 description 2EugenePC
 switchport access vlan 2
 spanning-tree portfast
 !
!
interface Dot11Radio0
 description WiFi Access Point
 no ip address
 !
 encryption mode ciphers tkip
 !
 ssid 877W
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 world-mode dot11d country RU both
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 !
!
interface Vlan1
 description description Ethernet&WiFi
 no ip address
 bridge-group 1
 !
!
interface Vlan2
 description TV
 no ip address
 bridge-group 2
 bridge-group 2 spanning-disabled
 !
!
interface Dialer0
 ip address negotiated
 ip access-group 101 in
 ip mtu 1492
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip nat outside
 ip inspect DEFAULT100 out
 ip virtual-reassembly max-reassemblies 128
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname <skip>@mtu
 ppp chap password 7 <skip>
 no cdp enable
 !
!
interface BVI1
 description LAN
 ip address 192.168.1.1 255.255.255.0
 ip access-group 100 in
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 !
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip flow-top-talkers
 top 5
 sort-by bytes
 cache-timeout 3600
!
ip dns server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.2 57649 interface Dialer0 57649
ip nat inside source static udp 192.168.1.2 57649 interface Dialer0 57649
ip nat inside source static tcp 192.168.1.63 20 interface Dialer0 20
ip nat inside source static tcp 192.168.1.63 221 interface Dialer0 221
ip nat inside source static tcp 192.168.1.63 55536 interface Dialer0 55536
ip nat inside source static tcp 192.168.1.63 55537 interface Dialer0 55537
ip nat inside source static tcp 192.168.1.63 55538 interface Dialer0 55538
ip nat inside source static tcp 192.168.1.63 55539 interface Dialer0 55539
ip nat inside source static tcp 192.168.1.63 55540 interface Dialer0 55540
ip nat inside source static tcp 192.168.1.63 55541 interface Dialer0 55541
ip nat inside source static tcp 192.168.1.63 55542 interface Dialer0 55542
ip nat inside source static tcp 192.168.1.63 55543 interface Dialer0 55543
ip nat inside source static tcp 192.168.1.63 55544 interface Dialer0 55544
ip route 0.0.0.0 0.0.0.0 Dialer0
!
kron occurrence TIME in 2:0 recurring
!
kron policy-list TIME
 cli ntp server nist.time.gov source di0
!
logging 192.168.1.2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 100 remark CCP_ACL Category=17
access-list 100 remark Auto generated by SDM for NTP (123) time.nist.gov
access-list 100 permit udp host 192.43.244.18 eq ntp host 192.168.1.1 eq ntp
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 permit ip any any
access-list 100 permit icmp any any
access-list 101 remark CCP_ACL Category=17
access-list 101 remark Auto generated by SDM for NTP (123) time.nist.gov
access-list 101 permit udp host 192.43.244.18 eq ntp any eq ntp
access-list 101 permit udp host 156.154.70.22 eq domain any
access-list 101 permit udp host 156.154.71.22 eq domain any
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any unreachable
access-list 101 permit tcp any any eq 57649
access-list 101 permit udp any any eq 57649
access-list 101 permit tcp any any eq 20
access-list 101 permit tcp any any eq 221
access-list 101 permit tcp any any eq 55536
access-list 101 permit tcp any any eq 55537
access-list 101 permit tcp any any eq 55538
access-list 101 permit tcp any any eq 55539
access-list 101 permit tcp any any eq 55540
access-list 101 permit tcp any any eq 55541
access-list 101 permit tcp any any eq 55542
access-list 101 permit tcp any any eq 55543
access-list 101 permit tcp any any eq 55544
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   ip host 0.0.0.0 any
access-list 101 deny   ip any any
dialer-list 1 protocol ip permit
!
!
!
!
snmp-server community public RW
snmp-server host 192.168.1.2 <skip>
!
control-plane
 !
!
bridge 1 protocol ieee
bridge 1 route ip
banner login Cisco 877W access router ready

!
line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 access-class 23 in
 login local
 length 0
 transport input telnet ssh
!
scheduler max-task-time 5000
ntp clock-period 17175037
ntp server 192.43.244.18 prefer
end

Could somebody advise?
0
Comment
Question by:MiZN
  • 2
  • 2
5 Comments
 
LVL 7

Accepted Solution

by:
CSorg earned 500 total points
ID: 36559356
0
 

Author Comment

by:MiZN
ID: 36565302
Yes, solution is like that:
 ip ddns update method name1_dyndns
 HTTP
   https://username:password@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
exit
interval maximum 0 5 0 0
interval minimum 0 5 0 0
exit
ip ddns update method name2_dyndns
 HTTP
   https://username:password@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
exit
interval maximum 0 5 0 0
interval minimum 0 5 0 0
exit
int Dialer0
 ip ddns update hostname name1.dyndns.org
 ip ddns update name1_dyndns
 ip ddns update hostname name2.dyndns.org
 ip ddns update name2_dyndns
0
 

Author Comment

by:MiZN
ID: 36566203
I've requested that this question be closed as follows:

Accepted answer: 0 points for MiZN's comment http:/Q_27314977.html#36565302

for the following reason:

It isn't exact solution due to I used formal names (name1 and name2)
0
 
LVL 7

Expert Comment

by:CSorg
ID: 36566204
I believe I pointed the TS to the right solution
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now