Solved

Use RV042 with PPPoA connection via bridged modem

Posted on 2011-09-19
35
4,092 Views
Last Modified: 2012-08-14
Hi,

 

I  have recently purchased the rv042, I have two broadband connections  both PPPoA, the first has a static IP and connects with the rv042 no  problem (via a Thompson 585v7 in bridge mode).

 

The  second has a dynamic IP. I have set the Thompson 585 'modem' in to  bridge mode and when I connect via Ethernet to a PC, the PC is given an  external IP...ie bridge mode working correctly.

 

In  the rv042 I set the WAN2 connection type as PPPoE, however the rv042  requires a username and password and my ISP does not use one.

When  I click save setting on the rv042 the display is updated with some  characters in the password field, even though I left them blank.

 

I have followed the full procedure from this article:

http://www.cisco.com/en/US/products/ps9923/products_qanda_item09186a0080a369fb.shtml

 

expect entering the username and password as there isn't one.

 

My ISP's settings can be seen here:

http://www.beusergroup.co.uk/technotes/index.php?title=Settings_for_other_routers

RV042 firmware version: 1.3.13.02-tm

Thompson routers both have latest firmware.

 

Any support with this issue would be greatly appreciated.
0
Comment
Question by:rohitgorasia1
  • 19
  • 16
35 Comments
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 36560996
The choices you have in the older RV042 with that firmware are:

-Static IP
- Obtain an IP automatically
- PPPOE
- PPTP
- Heart beat signal

Based on your description of a PC working, it looks like you need "Obtain an IP automatically".

You have to hook it up to see the result of course.

The password is usually filled with fake place-holder symbols I do believe.  Also, I don't know if the RV042 will accept a [blank] password, haven't tried it.  Ii recommend you assign it a simple one of your own.  The default login is admin/admin.
0
 

Author Comment

by:rohitgorasia1
ID: 36565913
Thanks for the reply,

I have tried that and it still is unable to obtain an IP from my ISP.

When I try to renew the WAN2 IP all i get is 0.0.0.0

Do you think I may need to clone the MAC address of my modem.
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 36569399
I would only use bridge mode if I had to.  And that seems if you have to have a public IP on the RV042 ... why?
And that seems if you have particular passthrough requirements ... do you?
Looks like it's probably best to use the Thomson in the normal NAT mode.
0
 

Author Comment

by:rohitgorasia1
ID: 36569775
I would like to avoid double natting if possible
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 36571154
Then set up the RV042 in Router mode.  That works and won't entail NAT .. although it will entail another subnet range.

I'm using them like this:

RV042 as an internet gateway (no modem) but does do PPPOE.
Firewall with NAT
RV042 in router mode to remote site (WAN1 pointing INTO the firewall's LAN)
(interim subnet 192.168.222.0 /24 between the two RV042's here)
remote site:
RV042 in router mode to main site (WAN1 pointing toward the main site)
RV042 LAN on remote LAN

So, the only NAT is in the firewall....
0
 

Author Comment

by:rohitgorasia1
ID: 36597968
I cannot even get it to work in double natting.
I have reset my modem and then connected that to wan two and asked the rv042 to obtain the ip automatically.

Im now having trouble loging into the modem, so will have to sort that out first!
0
 

Author Comment

by:rohitgorasia1
ID: 36899028
I have now reset the thopson router with a dhcp ranger 192.168.2.1-100.

so when i plug a pc to the rother its IP is within that range.

when i connect the router to the rv042 wan port and select optain ip automatically, i still am unable to get a wan2 IP.
0
 

Author Comment

by:rohitgorasia1
ID: 36899032
I have also set the rv042 wan2 as a static IP..

192.168.2.102

and the connected the router, but the rv042 summary page still shows wan2 ip as 0.0.0.0
0
 

Author Comment

by:rohitgorasia1
ID: 37011152
Fmarshall... I have tired and retried everthing above...do you have any further suggestions??

Thanks in advance!
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37011224
OK - well it sounds like you have the RV042 in failover mode (Smart Link Backup) with WAN1 as the primary and WAN2 as the backup.  In this mode the IP for WAN2 willl show as 0.0.0.0 until it fails over.

Two things you can try:
1) In System Management / Dual WAN the selection of Smart Mode Backup OR Load Balance is important.  Which is it?  If it's in Smart Mode Backup then the IP behavior sounds normal.  Set the Primary WAN to WAN2 just to see what happens to the IP under the System Summary.
2) Pull out the WAN1 cable and see if the same doesn't happen with WAN2 IP when WAN1 is primary.

Check these things:
In Setup / Advanced Routing is the Working Mode Gateway or Router?  Gateway is NAT and Router is not NAT.  I have found some of my installations will not work in Gateway mode.  And, this gets rid of double NAT.
0
 

Author Comment

by:rohitgorasia1
ID: 37011537
Thanks for the quick reply...

You were right I did have the RV042 in failover mode. However putting in back into Load balance had no effect. This is with the TG585v7 in bridge mode as well as with just a gateway adress of 192.168.2.1 and DHCP turned on and working correctley. In both cases the RV042 was set to 'obtain IP automatically' and in gateway mode.

With the RV042 in router mode, none of my internal devices can ping an external IP

With the RV042 in failover mode and the primary WAN set to WAN2, there is still no WAN2 IP is the system summary page

Pulling the WAN1 cable makes on effect to the WAN2 IP.

I'm not sure what I'm doing wrong!!

0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37011685
OK - then this seems to indicate that you can't get an IP address on WAN2.

"With the RV042 in failover mode and the primary WAN set to WAN2, there is still no WAN2 IP is the system summary page "
"Pulling the WAN1 cable makes on effect to the WAN2 IP."
Presumably this was when in failover mode with WAN1 the primary, eh?  
Anyway, this is why I say that it appears you can't get an IP address on WAN2.

So, I'd concentrate on this one aspect first.  
To do that, you might try this:
Put it in failover mode with WAN2 the primary and nothing connected to WAN1.
Then you should be working consistently with WAN2.

****************************

Turn off the Thompson firewall at least until you know that things are working.

It's not entirely clear to me what you mean by:
"The  second has a dynamic IP. I have set the Thompson 585 'modem' in to  bridge mode and when I connect via Ethernet to a PC, the PC is given an  external IP...ie bridge mode working correctly."
The Thompson manual doesn't really talk about "bridge mode" .. so maybe there's another term.  But I sure do see a lot about setting up a broadband connection on a PC .. which is NOT what you want.  Or, in other words, you want the RV042 to be the "PC" - in whatever mode is necessary.

Here is what I'd do after turning off the firewall:

Connect a PC to each Thompson modem/router directly.
Set the Thompsons both up to be "normal" NATting modem/router with DHCP enabled.
Get a connection and a public IP address on each.

Now, set the LAN on one of them to 192.168.0.0 / 255.255.255.0 and set the LAN address of the router to 192.168.0.254 just for consistency.
I am assuming that the RV042 LAN subnet is NOT 192.168.0.0 NOR 192.168.1.0.
What you need are 3 different subnets:
One for WAN1, one for WAN2 and one for the RV042 LAN .. your network subnet.
I will assume that your LAN subnet is 192.168.2.0.

OK.  So now you should be able to look at 192.168.1.254 and see that it has an internet connection.
And now you should be able to change the PC IP address to something like 192.168.0.2 and look at 192.168.0.254 and see that it has an internet connection.
And, do this using "get an address automatically" on the PC so you confirm that DHCP is working.

Now connect the PC to the RV042 LAN.
Set the LAN to provide DHCP.
Set WAN1 to get its address automatically.
Set WAN2 to get its address automatically.
Change the RV042 LAN subnet to 192.168.2.0 / 255.255.255.0 with an address of 192.168.2.254.
Release and restore the PC IP address so it will be on this same subnet.

Set the RV042 to Load Balance under System Management.

Now connect WAN1 and WAN2 to the Thompson routers.
With a browser:
You should be able to see the RV042 control panel at 192.168.2.1
You should be able to see the Thompson at 192.168.1.254 and its public IP address.
You should be able to see the Thompson at 192.168.0.254 and its public IP address.
You should be able to see the WAN1 address in the range 192.168.1.0 at the RV042.
You should be able to see the WAN2 address in the range 192.168.0.0 at the RV042.
You should be able to see web pages with either WAN1 disconnected or WAN2 disconnected.

On the RV042, go to Setup / Advance Routing.  At the bottom of the page click on "Show Routing Table".
You will be able to highlight all the table entries, copy them and then paste into a text file.
Paste the results here.

I know that this is double NAT for now but getting it to work first seems important.

We should be able to get rid of the RV042 NAT in a second step.






**************************

"With the RV042 in router mode, none of my internal devices can ping an external IP"
Well, I don't know how you have it set up "with the RV042 in router mode".  There have been so many variations in what you've set up.
0
 

Author Comment

by:rohitgorasia1
ID: 37014068
I believe your diagnosis is correct. I cannot get an ip on wan2.
I have had wan1 working with a static ip and my tg585 in bridge mode.

I just tried putting those settings into wan 2 and connecting the wan2 port to that tg585.
with the following dual wan settings.
1. Smart link backup primary wan 1
2. Smart link backp primary wan 2
3. Load balance.

Wan1 was left unconnected

I was unable to get an external ping using any of these settings. I also tried changing from gateway to router mode. This made no difference.  


the other thing I tried was to get my other tg585 working in normal natting with the subnet 192.168.2.0 default gateway 192.168.2.1 (the rv042 has subnet 192.168.1.0 and default gateway 192.168.1.1).
I turned the firewall off on the tg585 and connected to wan 1 (as I know I have had this port working) I set the rv042 to obtain the ip automatically. The summary page displayed an ip of 192.168.2.7 hence it had automatically obtained it from the tg585 via dhcp. I was able to get an external ping.

I am unable to do this from wan2, with any dual wan setting or in router or gateway mode.

So to summarise wan2 is unable to connect whether I use the 585 in bridge with static ip or in normally natting whilst wan1 can connect in both circumstances.

This leads me to believe that there is a physical fault with wan port 2. Would you agree with this?
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37015425
Possible there's a problem with the RV042.
In that case I would reload the firmware for starters.

Have you tried this?

With the tg585 providing DHCP in 192.168.2.0 or any other...
Set the WAN2 IP manually to 192.168.2.99 or some other suitable address ...
Set the DNS on the WAN2 to some suitable ISP DNS address.

Does it work then?
0
 

Author Comment

by:rohitgorasia1
ID: 37016779
Setting the WAN2 IP manually, sound like a good idea.
I will try that later today!

0
 

Author Comment

by:rohitgorasia1
ID: 37021167
I had the TG585 in DHCP working correctly. I plugged into wan2 and set the
ip as 192.168.2.99 gateway
as 192.168.2.1
subnet as 255.255.255.0
dns as 8.8.8.8
RV042 in load balance

The summary page shows an IP (as you would expect if you manually entered a static IP)

During this I had wan1 setup and working correclty in bridge mode.

I rang a ping to 8.8.8.8 and noticed every 4th or 5th packet was dropped.
I then unpluged wan1 and ALL packets were dropped
Next I repluged wan1 and unplugged wan2 and NO packets were dropped

I tried this several times with reboots of both the modems and the rv042 to no avail. I also swaped to rouer mode, but this caused all of the packets to fail not just the 4th or 5th.
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37021240
Well, at last some progress!

It appears that Load Balance may cause some ping losses.  Actually some ping losses are normal in internet paths.

I should think that if you ran enough tracerts un Load Balance mode that some of them would traverse WAN2.  That would be worth a try to see if it's working.  

The Router mode should work; you'll need "interim" LAN subnets for both WANs that are different.  It appears you've done that.

I'd be interested in knowing what happens if you put it in Smart Link Backup (i.e. failover) mode and switch the primary between WAN1 and WAN2.

I'm still unclear as to the subnets you're using.  There should be 3 private subnets.  What are they?
I'd like to see a routing table from the RV042 in each mode - those that work and those that don't work.  That could tell a lot!!
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:rohitgorasia1
ID: 37027782
I have just tired tracerts whilst in load balance mode
line 1 shows the rv042 (192.168.1.1)
line 2 always shows 'request timed out'
sometimes the tracert compleate and other times it reports destination host unreachable.

I do have interim subnetsthat are diffrent but WAN1 is not a LAN subnet....
to clarify....

RV042 - subnet 192.168.1.0
WAN2 - subnet 192.168.2.0 (TG585 in DHCP)
WAN1 - subnet 78.105.7.0 (TG585 in Bridge)


See routing table attached!

 
route-table.txt
0
 

Author Comment

by:rohitgorasia1
ID: 37027895
Also,

You say dropped packets are normal when using load balanceing, but surely it shouldn't look like this....(see attached file)

you can actually see where i unplugged the wan2 cable
ping.txt
0
 
LVL 25

Assisted Solution

by:Fred Marshall
Fred Marshall earned 500 total points
ID: 37032395
OK.  That's helpful.  Sorry it's taken me a while to get back to it.

The routing table looks fine and clarifies the address structure at the same time.

I'd not expect the ping results that you see.  In experiments I've done with forced failovers, the delay has generally been one ping.  But you have it in Load Balance mode and I guess I'm not as surprised with that.  I've read reports of slowness when in Load Balance mode but I can't confirm what was going on in those cases.

I wonder .... this is just a stab in the dark ... one of the WAN addresses is public and the other is private.  The rules for routing for one or the other are different.  So I wonder if the RV042 is getting confused over this?  I shouldn't think so as the routing table seems fine.  That is, private addresses aren't supposed to be routed on the internet.  This means to me (but don't ask me about particular implementations) that a ping to a private address via a WAN port having a public address should be dropped.  In that case, 0.0.0.0 means "everything except private addresses".  I think that's the rule.  Otherwise the router would toss all kinds of strange traffic out onto the internet port.  But, if the WAN address is private, then 0.0.0.0 apparently means something else.  Certainly you can route between two private subnets.  My point here is that the rules may differ somewhat depending on the nature of the WAN addresses.  If you load balance between a public and a private subnet range then I wonder how all that comes together in this particular device model?

I have seen some flaky things with the RV042 recently.  Here they are:

I can reach the next router on the WAN1 subnet (for example to open its http control panel) but I cannot reach the next router on the WAN2 subnet.  I can ping the latter from the Diagnostics in the RV042 but not from a computer on the LAN side.  So that seems odd.

Also, as this thread has been going on, I believe I caught the same RV042 stuck in Load Balance mode  (both WANs listed in the Routing Table)  when that is not a mode I'm using at all.  A reboot didn't help.  So, I switched it to Load Balance and then back toSmart Link (failover) and it seemed to go back into that mode.   This is concerning.  It's possible that we both are working with flaky units.  It would be worth replacing the one your have to see if it doesn't help .. because I can't duplicate your problem.  Now, I *have* seen both entries in the Routing Table briefly after a failover.  But that condition cleared fairly quickly thereafter.

Could there be a bad cable on WAN2?  I think that could cause what you're seeing if the setup is static.  If it's dynamic/DHCP then we see the Gateway of 192.168.2.1 which implies a connection, etc. via DHCP.

Did you assign these addresses statically/manually?  They need to be different than the router they are connected to.  So, if one is 192.168.2.1 then you should set the WAN address at something like 192.168.2.2 or .99 or..... anything that's in the subnet but not the same.  I suppose you know this but I mention it for completeness.

I guess the WAN1 address is via DHCP from the ISP because it's a public address, right?  That's the "bridge mode" in the Thompson, right?  So, this comment applies particularly to the WAN2 IP address.

If you use the RV042 Diagnostics, can you ping the WAN2 Gateway?  Can you ping the RV042 WAN2 IP address?
In failover mode the primary will have to be WAN2 for this to work.

0
 

Author Comment

by:rohitgorasia1
ID: 37049982
Sorry for the late reply....been snowed under over here...

I gonna spend the day looking at this....I'll report my findings...

My firmware is 1.3.13.02-tm
on the cisco website there a firmware 4.x.x.x for the rv042
what is this about??

0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37050720
There are two versions of the hardware.  Those marked Linksys and newer ones marked Cisco.

The Cisco is V.3 hardware.  The Linksys is a version or two earlier than 3.

The 4. firmware is for v.3 hardware.    

So, if you have 1.3.13.02-tm then that's means you have the Linksys hardware.  And, the one you have is the most recent release.



0
 

Accepted Solution

by:
rohitgorasia1 earned 0 total points
ID: 37075191
I decided to backup the router setting and restore the RV042 to factory settings.
I then set up WAN2 with the 192.168.2.0 subnet and low and behold everything worked correctly.
I then reimported the backed up setting, set up the WAN2 again and now WAN1 & WAN2 both seem to be working correctly.

I have left it running for the past few days and the load balancing seems to be working.
I attach herewith the system statistics. What are your thoughts?


The only problem I seem to be having is with log me in.
I cannot log on to the service as my IP keeps changing, I might need to force some sort of traffic though a specific wan.


sys-stats.txt
0
 
LVL 25

Assisted Solution

by:Fred Marshall
Fred Marshall earned 500 total points
ID: 37077015
I'd say those statistics look pretty impressive - the load balancing seems to be working.  

As far as the LogMeIn issue, I have no idea what the Load Balancing algorithm might be but it's clear it doesn't "like" this setup.  You might try adding a static route:
To [LogMeIn IP Address via ONE of your [WAN IP address] .. just to see what happens.

I use GoToAssist and it survives failover switches.  I've not tried it in Load Balancing.
0
 

Author Comment

by:rohitgorasia1
ID: 37093141
I tried to add a static route but the help info says
"In order to use static routing, the Router's DHCP settings must be disabled."

I want to use DHCP.

I could foward all HTML traffic to a particular WAN port, but I would much rather force all trafiic to a particular IP to go through a WAN.

Any ideas of how todo this without disabling DHCP?
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37097681
Adding a static route has nothing to do with DHCP.

You go to Setup / More > ...... / Advanced Routing
On that page you add static routes which end up in the Routing Table.
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37098010
Perhaps I spoke too soon.
If you have a WAN address assigned by DHCP then I guess you can't route to the latest address .. which I guess would be the Default Gateway in the route.
But I wonder if you wouldn't route it to the non-DHCP interface?  If that applies here.  I thought it did......
0
 

Author Comment

by:rohitgorasia1
ID: 37099119
Hmm.. I also couldn't understand why statics routes has anything todo with DHCP.
but when i go to Setup / More > ...... / Advanced Routing...and then click more on the right hand pane.

the help file reads:

Static Routing:

You will need to configure Static Routing if there are multiple routers installed on your network. The static routing function determines the path that data follows over your network before and after it passes through the Router. You can use static routing to allow different IP domain users to access the Internet through this device. This is an advanced feature. Please proceed with caution.

This Router is also capable of dynamic routing (see the Dynamic Routing tab). In many cases, it is better to use dynamic routing because the function will allow the Router to automatically adjust to physical changes in the network's layout. In order to use static routing, the Router's DHCP settings must be disabled.

0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37105216
Well, I guess I'd say "it depends".   (The help files are pretty cryptic).

- If the static route you want to add is completely on the LAN side then it has nothing to do with DHCP on the WAN side.  And it should not involve any LAN address within the scope of any LAN side DHCP.
The reason being that you don't want to route to addresses that may change.  So those addresses should be static.

- By the same token, if the WAN side address is obtained via DHCP then you wouldn't like want to try to route to the WAN address.  In this case it's better to set the WAN address manually (static) in a way that's consistent with the WAN.  If the WAN is by PPPOE or some such then you may be out of luck in this regard.
0
 

Author Comment

by:rohitgorasia1
ID: 37105926
Sorry fmarshall if I am being a bit slow...But I'm a liitle confused.

Say for example I would like any PC on my network to visting the log me in website via WAN1

Then should I use static routes with the following settings:

Destination IP
Log me in IP (74.201.75.199)

Subnet Mask:
My subnet mask?

Default Gateway:
My Default Gateway?

Hop count:
Default 15

Wan interface:
The interface I would like to use (WAN1) or the interface the request is coming from (LAN)

Cheers
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37109079
I would try it this way:

Destination IP 74.201.75.199
Subnet mask 255.255.255.255 <means this desitnation and only this destination
Default Gateway The WAN IP that you intend to use ... this is why the WAN should not be getting its IP address via DHCP
Hop count: Default 15 is OK
WAN interface to match the WAN address above (e.g. WAN1 here)

I tried it and it seems to work as far as the routing table accepting the new route.
Just remember to Save before looking at the routing table after making the Added entry.
0
 

Author Closing Comment

by:rohitgorasia1
ID: 37163680
Thanks for your help fmarshall.

You are both a gentlemen and a scholar.

Re: the logmein issue - this is probably a separate questions

Many Thanks

RG
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37164655
Thank you for the points!
Does it work now?
0
 

Author Comment

by:rohitgorasia1
ID: 37164895
Dual WAN is working a treat.
Logmein issue is intermittent.
For now I have forwarded all http and https traffic on a single internal ip to use WAN2.

This is an acceptable work around for now.
But I will look into this when I get sometime.

Thanks once again.
RG
0
 
LVL 25

Expert Comment

by:Fred Marshall
ID: 37164966
"Dual WAN is working a treat."  Good to hear!

"Logmein issue is intermittent.
For now I have forwarded all http and https traffic on a single internal ip to use WAN2."

I don't know how you do that...... so I'd question whether the implementation is working - thus the LogMeIn problem remains.
That is:
If you start with a particular computer on the LAN then the RV042 is the gateway (its LAN address) so I don't know how you route to WAN2 from there.
If you start inside the RV042, then I don't see any settings for what you describe.  Maybe I can learn something....
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Join & Write a Comment

Suggested Solutions

Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now