• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 515
  • Last Modified:

Windows 2008 PPTP VPN clients need host file to resolve server names. How to resolve?

Windows 2008 PPTP VPN clients need host file to resolve server names.  How to resolve?

Clearly DNS isn't being communicated over this connection.  Problem with DHCP, DNS server or RAS server?  THanks.
0
LB1234
Asked:
LB1234
  • 4
  • 4
2 Solutions
 
.Commented:
Hi,

If you go to nslookup you can change the nameserver being queried by issuing the server command then the IP/Server name, like the following example.

system:~ $ nslookup
> server 8.8.8.8
Default server: 8.8.8.8
Address: 8.8.8.8#53
www.redhat.com
Server:            8.8.8.8
Address:      8.8.8.8#53

This changes the server I am querying for www.redhat.com to 8.8.8.8 (Google). If you do the same when accessing VPN then change it to an internal Nameserver you will be able to see if you can successfully query DNS through the tunnel.

As a workaround you can edit the VPN Client to use your internal nameservers. Go to the VPN properties, Networking then TCP/IP properties. You can then Set the connection to use your Internal DNS.
0
 
LB1234Author Commented:
I'm aware that there are workaround, but I'm try to get to the root causes.  SHouldn't the VPN client get DNS information from a server so other modifications to the client settings are unnecessary?  
0
 
LB1234Author Commented:
Let me also add that the servers i'm talking about resolving are internal domain servers.
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
.Commented:
Is the remote machine joined to the domain?
0
 
LB1234Author Commented:
Yes.
0
 
.Commented:
Does it work if you use the FQDN then i.e server.domain.local ?

Sorry if there are more questions than answers.
0
 
LB1234Author Commented:
Hey it's no problem.  I understand the need for more information.  Let me test and get back to you on that tomorrow.
0
 
.Commented:
Ok thanks, if you find this works try setting a DNS search suffix via group policy. The search suffix will be your active directory domain name such as addomain.local for example.

http://www.techrepublic.com/blog/datacenter/manage-dns-suffix-configuration-through-group-policy/2665
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now