Solved

Outlook 2011 on Macos 10.6 - search yields no results

Posted on 2011-09-19
9
412 Views
Last Modified: 2013-02-15
Using search in Outlook 2011 yields no results.

However using a similar search in spotlight does give search results which suggests that the messages have been indexed?

Outlook version: 14.1.0
Macos: 10.6

Thanks
0
Comment
Question by:sakadava
  • 4
  • 3
9 Comments
 
LVL 7

Expert Comment

by:andymacf
ID: 36560496
Please see the attached screenshot, you have to click an extra button to search you outlook items.

Andy Outlook-find.tiff
0
 

Author Comment

by:sakadava
ID: 36560629
Hi Andy - what you described brings you to the search block but when I enter a search term Outlook displays "No results" even though an independent search using spotlight does result in search results.
Thanks anyhow.
Simon
0
 
LVL 7

Expert Comment

by:andymacf
ID: 36561091
Have you tried updating Outlook, I am running 14.1.2 and it works.  It also seems to take a while, I suppose this depends on how many emails you have.  Do you have the search parameters as shown in the attachment?

Andy Outlook-find2.tiff
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:sakadava
ID: 36561878
Hi Andy,

I don't think this is an Outlook version issue. I do have the search parameters shown in the attachment.

This is on a network login Mac. However when originally set up, Outlook consistently fell over (cause unknown) until the Outlook database was located on the local hard disk, using an alias to map it from its expected location on the user's now networked home folder. This resolved the Outlook crash but now I'm wondering if this has caused the issue with search.

After hunting around I noticed examples where people have relocated their Outlook database in this way, e.g.
http://aaltonen.us/2011/03/21/outlook-2011-for-mac-search-troubles/

I have checked that the location of the Outlook database is being indexed, and when I do searches using spotlight I can find the relevant e-mails. But when I use the Outlook quick search, or advanced search, it always comes up with no results.

Thanks for your help so far,
Simon


0
 
LVL 7

Expert Comment

by:andymacf
ID: 36561954
It would seem that Outlook is not looking at the same database location in that case. Have you tried removing the account and starting again?

Others talk about re-indexing the whole hard drive and leaving it until it finishes and this has sorted the problem.

When you migrate a profile from one Mac to another Mac you might find that the search will only work on new items in your Outlook after the migration. It doesn’t index the previous items.

In Mac OS X the search is called Spotlight. Below is what I’ve done to resolve it,

    Click on the little Apple Icon top left hand corner
    Click System Preferences
    Click Spotlight under Personal
    Click on Privacy and then the little +
    Click on Macintosh HD as the selection. This will exclude you HD from indexing and remove all indexes.
    Close the System Preferences.
    Open it again after a few seconds and remove the Macintosh HD from the Privacy selection.
    This will reindex the whole harddrive including all the Outlook items.
    After a while test by searching for items in Outlook and see if items appear from before migrating.
0
 

Author Comment

by:sakadava
ID: 36565571
Hi Andy,

I've removed the account and created it again.

I've re-indexed the whole hard drive.

Still Outlook search does not work although similar searches using spotlight do work correctly.

Any other ideas?

Simon
0
 

Accepted Solution

by:
sakadava earned 0 total points
ID: 36576606
I finally resolved this issue by rebuilding the database for the identity using the database utility.

I don't know why this should have been necessary given that the identity was new and presumably ought not have needed to have been rebuilt.

Rebuilding the identity wasn't entirely trivial because the database utility consistently crashed when attempting to do the rebuild. Although I had aliased the identity to the hard disk, the database utility was attempting to create a new identity on the networked drive and so was falling over. I mapped the parent directory Office 2011 Identities to the internal disk and this did the trick.

Why Outlook and the database utiility crash when using a networked folder I do not know. But I experienced a similar problem with Adobe Acrobat which needed a non-networked folder to get it working.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Set up iPhone and iPad email signatures to always send in high-quality HTML with this step-by step guide.
Sometimes Outlook might have problems sending a message. There may be various causes- corrupted PST, AV scanner etc. The message, instead of going to the Sent Items folder, sits in the Outbox indefinitely. To remove it you can use a free tool cal…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now