Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1465
  • Last Modified:

SSh-Tunnel via putty

Hi,

I succeeded to make a ssh-tunnel to my home network via putty (logged in, can ping ip's).

Now I would like to redirect my browser to be able to connect to my home configs, pc's. That what doesn't work. I've set firefox to use 127.0.0.1 on port 1080. Putty shows D1080 underneith the tunnel option.
Now when I try to connect to any address, it doesn't do anything. Don't know how to troulbeshoot since everything looks ok ....

Please advise.

J.
0
janhoedt
Asked:
janhoedt
1 Solution
 
Brian GeeCommented:
You have Firefox configured to use SOCKS for proxy connections, right?
0
 
janhoedtAuthor Commented:
Correct
0
 
janhoedtAuthor Commented:
Correct
0
IT Degree with Certifications Included

Aspire to become a network administrator, network security analyst, or computer and information systems manager? Make the most of your experience as an IT professional by earning your B.S. in Network Operations and Security.

 
Giovanni HewardCommented:
What OS and SSH server product are you using?
0
 
janhoedtAuthor Commented:
Xp and synology nas
0
 
mchkorgCommented:
a "dynamic" tunnel (SOCKS) works fine for ICQ/MSN/jabber and so on. I never managed to make it work for http/https trzafic.

To redirect your http/https trafic this way, I'd suggest you install a proxy software (like squid) on your server (I bet/hope your NAS can do it or maybe you can add packages) and then, you create a "local tunnel" in putty (not a dynamic one), say : 12345 to 127.0.0.1:3128
Then you tell firefox to use localhost:12345 as a proxy

127.0.0.1:3128 if your proxy is on the same host than SSH, otherwise you enter it's IP
3128 is the default port for squid

Regards
0
 
Giovanni HewardCommented:
I've actually configured two WinSSHD (Bitvise) servers in the last two weeks; both work great for all traffic (http/https included.)  If you need to redirect traffic from command-line (or any other applications which do not support proxies directly), I recommend Proxifier.  This point here is you do NOT generally need to configure a separate http/https proxy.

Going back to your problem... have you verified the user account itself has been configured on the server side to permit C2S/S2C port forwarding.  With WinSSHD, the port forwarding configuration is on the user/group configuration level rather than server.

0
 
janhoedtAuthor Commented:
Have been able to make it work. However only over an openvpn-tunnel.
http://www.nikhef.nl/~janjust/nikhef-proxy/, the thing is, only proxy socks 5 should be used.

Now this works over the proxy-tunnel, not when I go via putty only (directly to my dyndns-address), I get stuck at the proxy (port 80). It won't authenticate, however I've set the proxy-settings in putty.
Note: when I connect over port 8080 (they all redirect to port 22 = ssh on my NAS) it works fine, but I need port 8080 for my openvpn.

So in short: I can connect via putty to port 8080 (reroutes to 22 on my NAS), not via port 80 or 443 (also reroutes to 22 on my NAS), connection is stuck on proxy local network (work).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now