permalink problem

My blog is hosted on www.site.com/blog.
By mistake we linked from an important site to www.site.com/Blog.
For the strangest reason if you click on with a capital, you get a 404 worpress missing page.

What can I do to get around it?
rivkamakAsked:
Who is Participating?
 
gwkgConnect With a Mentor Commented:
I use the redirection plugin to catch 404 errors and redirect to the proper pages.

http://wordpress.org/extend/plugins/redirection/
0
 
jeremyjared74Commented:
I've dealt with this problem for another person that was experiencing the same error. The person was on a Linux hosted server, so if you are also try this:

Open a blank text document and paste this in it:
http://' .  getenv('HTTP_HOST') . strtolower($uri[0]) . $uri[1], true, 301); ?>

Open in new window


Save the files as lowercase.php and upload the the WordPress Root Directory (where the wp-config file is.

Next you need to open your .htaccess file and add this to the top:
Options +FollowSymLinks 
RewriteEngine On 
RewriteRule [A-Z] /lowercase.php [L]

Open in new window

0
 
rivkamakAuthor Commented:
What do I need to change if I have an IIS server?
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
jeremyjared74Commented:
IIS isn't my specialty, but I'll point you in the direction of an article that explains how. If you get stuck, let me know and I'll try to help:

http://learn.iis.net/page.aspx/465/url-rewrite-module-configuration-reference/
0
 
rivkamakAuthor Commented:
I made the changes in the url rewrite,., but it's not co-operating.
0
 
Jason C. LevineNo oneCommented:
IIS should be case-insensitive by default...why is yours doing this at all?
0
 
rivkamakAuthor Commented:
That's what I don't know.
you can check
http://www.oorah.org/blog
or http://www.oorah.org/Blog
0
 
Jason C. LevineNo oneCommented:
Ah-ha...that's not a true 404, that's WordPress attempting to find something and failing.

What you could do is create a page with /Blog/ as the slug and use:

http://wordpress.org/extend/plugins/simple-301-redirects/

to redirect it to /blog/
0
 
rivkamakAuthor Commented:
I can't create anythin with a capital.
I tried creating a page with /Blog/ and it saved it as /blog/
0
 
ovi_mihaiCommented:
Try a .htaccess redirection

Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^www.site.com/Blog [nc]
rewriterule ^(.*)$ http://www.site.com/blog/$1 [r=301,nc]

Open in new window

0
 
rivkamakAuthor Commented:
In Url Rewrite?
0
 
ovi_mihaiCommented:
create a text file named .htaccess and put in the root of the blog. the content is above and you get the 301 redirection
0
 
Jason C. LevineNo oneCommented:
ovi_mihai

He's running IIS.  Different rules apply.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.