?
Solved

Vista, Turn Windows  Feature On-Off doesn't work for IIS 6 Metabse and Configuration compatability.

Posted on 2011-09-19
10
Medium Priority
?
284 Views
Last Modified: 2012-05-12
Hi Guys,

I was trying to develop a website using VS2010 and trying to host it on local IIS (which is IIS7).
But i get the below message when trying to make the 'Web Location' as IIS.
----------------------------  Error ------------------------------------------
To access local IIS website, you must install  following IIS components:
IIS6 metabse and IIS6 Configuration compatability
ASP.NET
--------------------------------------------------------------------------------

I am using Vista Business and i have installed Vista SP1 and SP2 as well  along with VS 2010.
I can browse to IIS 7 using http://localhost

Also, as a Fix , i was trying to turn windows features ON for "IIS6 metabse and IIS6 Configuration compatability"  ... it throws me a windows saying "pls wait while features are configured....."   after 5-10mins it says "Error cannot install components ..."

Pls advice/suggest me to over this problem.

Thnaks
0
Comment
Question by:kishan66
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
10 Comments
 
LVL 17

Expert Comment

by:Rovastar
ID: 36562031
What features are you using that you need compatibility mode?
0
 

Author Comment

by:kishan66
ID: 36562514
As said, i'm trying to create a website using Microsoft visual studio 2010.

using Visual Studio, when i wanted to host on iis i get the message ......
" To access local IIS website, you must install  following IIS components:
IIS6 metabse and IIS6 Configuration compatability
ASP.NET
"

thanx
0
 
LVL 82

Expert Comment

by:David Johnson, CD, MVP
ID: 36584571
is uac turned on or is it disabled? many people have had success by logging in as the 'administrator' not just a member of the administrators group

net user administrator active:yes (to turn it on if disabled)
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 17

Expert Comment

by:Rovastar
ID: 36586701
"As said, i'm trying to create a website using Microsoft visual studio 2010.

using Visual Studio, when i wanted to host on iis i get the message ......
" To access local IIS website, you must install  following IIS components:
IIS6 metabse and IIS6 Configuration compatability
ASP.NET
"

thanx
"

Again what do you need IIS6 compaatability mode for you can create a website in VS2010 not using old features for IIS6 and just for IIS7. I suspect you have soem code tghat might need it but you seem unclear on your code.
0
 

Author Comment

by:kishan66
ID: 36587691
Hi Guys,

I am running as a administrator.

also,
 IIS error -- hosting webservice
0
 

Author Comment

by:kishan66
ID: 36587720
Also, IIS 7 is installed properlly. IIS& Works
0
 
LVL 82

Expert Comment

by:David Johnson, CD, MVP
ID: 36588878
many people have had success by logging in as the 'administrator' not just a member of the administrators group

Then you did not read my comment.. log in as 'administator' not a member of the administrators group which your user account is.
0
 

Author Comment

by:kishan66
ID: 36591250
ve3ofa,
pls understand, i am logged in as admin and i launched visual studio as administrator (right click visual studio - run as admin).
0
 
LVL 82

Accepted Solution

by:
David Johnson, CD, MVP earned 2000 total points
ID: 36591641
then please understand my comment to install the missing windows components i.e. to turn on the windows component log in as the 'administrator' not a member of the administrators group this account is hidden by default and you need to turn it on using the command net user administrator active: yes

you already tried to do this using your user account and got a permissions denied message.  I had said that many users have had this problem and by using the 'administrator' account it has fixed the problem when they could not do it with their user acount which is an 'administrator'
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question