Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

UT3 Dedicated Server Behind Cisco Router

Posted on 2011-09-19
8
Medium Priority
?
1,236 Views
Last Modified: 2012-06-21
I am attempting to setup a Dedicated UT3 LAN Server from behind a Cisco 2621 router running IOS 12.3(26) on a Windows Server 2008 R2 box.  The server, as far as I can tell, is correctly configured and will begin to start but then hangs up saying FSTUNClient timeout NAT is strict.  My NAT is setup as follows on the router:

 
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source static udp 192.168.1.51 13000 interface FastEthernet0/0 13000
ip nat inside source static udp 192.168.1.51 7777 interface FastEthernet0/0 7777
ip nat inside source static udp 192.168.1.51 6500 interface FastEthernet0/0 6500
ip nat inside source static tcp 192.168.1.101 3389 interface FastEthernet0/0 3389
ip nat inside source static tcp 192.168.1.51 3390 interface FastEthernet0/0 3390
no ip http server
no ip http secure-server
ip classless
!
!
access-list 1 permit 192.168.1.0 0.0.0.255

Open in new window


The UT3 server is running on 192.168.1.51 and according to all documentation, only ports 7777, 6500, and 13000 need to be forwarded to it.  Here is a picture of where the server hangs:
 UT3 Server Hangup
Now if I add "-multihome=x.x.x.x" where the IP is my EXTERNAL IP, the NAT resolves just fine and the server continues to load HOWEVER, before that point I get port bind errors because it can't bind any ports to that IP address (because it isnt the IP address of the server).  So far, I have not been able to get anywhere...  Any ideas?
0
Comment
Question by:dumpsterdivingdave
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 63

Expert Comment

by:☠ MASQ ☠
ID: 36563264
Can you add:
7778
7787
And
27900
To the list of forwarded ports for UT3?

0
 
LVL 5

Author Comment

by:dumpsterdivingdave
ID: 36563298
Same result.
0
 
LVL 5

Author Comment

by:dumpsterdivingdave
ID: 36563359
FYI, Here is what I see if I set the multihome switch to my external IP:
 NAT Open, port binding fails etc.
And here is a copy of my startup batch file:
 
ut3.exe Server CTF-NanoBlack?Game=UT3GoldGame.UTGreedGame_Content?Mutator=UTGame.UTMutator_Instagib,UTGame.UTMutator_Hero?Numplay=2?MaxPlayers=18?NumPublicConnections=16?NumPrivateConnections=1?MinNetPlayers=1?TimeLimit=35?GoalScore=20?BotSkill=3?bIsDedicated=true?bIsLanMatch=true?bUsesStats=false?ForceRespawn=0?bShouldAdvertise=true?PureServer=1?bAllowJoinInProgress=true? -multihome=192.168.1.51 -port=7777 -queryport=6500 -Login=XXX -Password=XXX -nohomedir -Log=myserver.log -unattended

Open in new window

0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 63

Expert Comment

by:☠ MASQ ☠
ID: 36563386
And change the UDP handling by changing the STUN server settings in UT's configuration.
http://mususumbra.blogspot.com/2007/12/hosting-ut3-games-truly-daft-solution.html
0
 
LVL 5

Author Comment

by:dumpsterdivingdave
ID: 36563444
It will now say NAT is open, however it hangs there and acts as if NAT is still strict.
 NAT Open, still hanging
0
 
LVL 63

Accepted Solution

by:
☠ MASQ ☠ earned 2000 total points
ID: 36563632
I think this is less NAT now and more UT3 configuration check your entries for maps in AutoLoadPrefixes all apply to valid maps.
0
 
LVL 5

Author Comment

by:dumpsterdivingdave
ID: 36566860
Well, I took a lok at the maps file, and everything there seems in order.  While doing this, the remote desktop connection started flaking out on me.  I disabled that nic and switched the -multihome switch to the other nic so that it was 192.168.1.52.  I also read somewhere that you have to create the server account from inside of UT3 not from the gamespy site.  After launching UT3 on my computer and creating a new account from inside there and logging in, I replaced those variables on the server startup script and it showed up in my list of LAN server and was joinable/playable.  I will re-verify that everything is working when I get home tonight just to be sure.
0
 
LVL 5

Author Closing Comment

by:dumpsterdivingdave
ID: 36583610
Turns out that it wasn't a NAT problem after all, but a NIC problem.  After switching NIC's everything works great.  Thanks for the suggestion to look beyond the NAT.
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question