Solved

Exchange 2007 Shared Resource

Posted on 2011-09-19
3
310 Views
Last Modified: 2012-05-12
I have had a few requests to create a shared calendar for a department so that a supervisor can easily and quickly reference to see when meetings are set up with external growers that we work with. Initially I create a mail enable Public Folder Calendar, but that quickly proved to be lacking some required features. Now I am looking at creating a resource calendar like a Resource Room Calendar.

I read that you can create a shared mailbox that is a resource mailbox. http://blogs.technet.com/b/exchange/archive/2009/02/26/3407028.aspx
But I have not been able to get it to auto accept like i can with the other Room Mailboxes. The shell command does not seem to work the same for this mailbox.

[PS] C:\Windows\system32>Set-MailboxCalendarSettings -Identity "GCC" -AutomatePr
ocessing AutoAccept
Set-MailboxCalendarSettings : AutoAccept can only be enabled on resource mailbo
xes.
At line:1 char:28
+ Set-MailboxCalendarSettings <<<<  -Identity "GCC" -AutomateProcessing AutoAcc
ept
    + CategoryInfo          : InvalidData: (vand1.oppy.com/Users/GCC:ADObjectI
   d) [Set-MailboxCalendarSettings], ResourceOnlyException
    + FullyQualifiedErrorId : A7488657,Microsoft.Exchange.Management.Recipient
   Tasks.SetMailboxCalendarSettings

Does anyone have any ideas on how to get this to auto accept or have you implemented something else to achieve similar results?
0
Comment
Question by:damte
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 36563344
Have you tried:

get-mailbox | where{$_.ResourceType -eq “Room”} | Set-CalendarProcessing -AutomateProcessing AutoAccept

Open in new window

0
 

Author Comment

by:damte
ID: 36563369
This is a not a room resource. We have resource rooms and I do not want to confuse users with additional rooms that are not actually rooms. I created this resource as a shared resource.

new-mailbox .... -shared
http://blogs.technet.com/b/exchange/archive/2009/02/26/3407028.aspx
0
 
LVL 21

Accepted Solution

by:
Hendrik Wiese earned 500 total points
ID: 36563412
Try to enable the user account and then logon to the mailbox using OWA.  Once in OWA, go into Options -> Calendar -> Resource Scheduling and see if it is enabled.

Reference: http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/f87c8cef-860d-4806-9f1a-4f71bc404247/
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
This video discusses moving either the default database or any database to a new volume.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question