Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3368
  • Last Modified:

column settings - greyed out

I have enabled management of content types on a list.
I click on "item" and then I click on the column name.
The option to select "hidden(will not appear on forms)" is greyed out.
I check other columns on the list and the option is there.
This column is a yes/no checkbox.

Is that why I can't select it or should this be able to be hidden just like any other item content type?
0
QPR
Asked:
QPR
  • 2
1 Solution
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Hello QPR,

I see the same behaviour, but don't have an explanation. When I change the column from a yes/no checkbox to text or choice (with yes/no as options), i can hide it from the form.

Since you want to hide it, and a yes/no checkbox would only hold TRUE/FALSE, you could use a choice field with TRUE/FALSE as options instead?

Clunky, but at least the column could be hidden.

cheers, teylyn
0
 
QPRAuthor Commented:
Thanks teylyn.
Yep that works, just changed it and did some testing (column is part of a workflow condition) and all good. Can only assume that checkbox columns can't be hidden or it's a bug.

Thanks.
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Thanks for the grade!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now