Solved

Windows Vista Can't start the Spooler; D Click it in computer management get failed to read and error code 2; R click then properties get "general internal error occured sys cant find file specfied"

Posted on 2011-09-19
16
835 Views
Last Modified: 2012-05-12
Windows Vista Can't start the Spooler; D Click it in computer management get failed to read and error code 2; R click then properties get "general internal error occured sys cant find file specfied"
I then get a pop up that says windows could not start the spooler service on local computer error 5 access denied.
 I also tried from the cmd        sc config spooler depend= RPCSS      got access denied?
0
Comment
Question by:Seastang
  • 8
  • 4
  • 2
  • +2
16 Comments
 

Author Comment

by:Seastang
ID: 36564632
I right clicked  the  CMD icon an went to admin and ran the above  Command ' sc config spooler depend= RPCSS   ' it was successful however I still can't start the Spooler still fails.
0
 
LVL 23

Expert Comment

by:redrumkev
ID: 36564635
Seastang,

How are you doing?

Are you logged in as a user or as administrator? You need to be logged in as Admin.

Did this printer ever work with Vista? Some drivers are not Vista compatible, so check that. Also, do you have the most up-to-date driver installed?

Check in C:\Windows\System32\spool\PRINTERS to make sure that there are no files. If there are some, delete these as they are old "tried to print" files, spool crash files. You have to be admin or elevate privilages to get into this folder (at least on win 7, I did).

See this posting: http://social.technet.microsoft.com/Forums/en-US/itprovistaprinting/thread/3b16edb0-74be-43b9-b554-60bca7b6c3e0/
LOTS of different solutions provided, a later one, suggests the following process:

"we had to delete the outstanding  print job, disconnect the printer.
refresh all printer settings   and printer drivers.
restart the  printer spooler
reconnect the printer

this solved  our printing problems  with normal documents
to enable  the  printing of pdf files   we had to uninstall  the Adope  program   and installed another
alternative  pdf reader.

This solved our problem     There must be a  big bug in the adope program  or the HP driver. This error only occurs with Vista  not  with XP   and only with our hp printers".


Hopefully this helps.
0
 

Author Comment

by:Seastang
ID: 36564781
Hi Redrumkev,

I did try at elevated Admin level. Yes, the printer had been work fine until Sept/12 or 13/2011
I'm working on this computer through remote access and wont be able to access it again until tommrow (tuesday) afternoon. I will look over the solutions at the hyperlink above

Thanx
Seastang
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 66

Expert Comment

by:johnb6767
ID: 36566941
I dont have a Vista machine to check these exact steps, but I use this the same scenario in XP/7 to clear out the Print Drivers which is usually whats causing it to fail...

Remove all physical printers (should be fine to leave Adobe PDF/Cute PDF/Snagit etc...).

Once the printer(s) is deleted, go to start>, and type CMD (Right Click, and "Run As Administrator"

net stop spooler
net start spooler

In the Printers Control Panel Applet>Right click in the window and select "Server Properties>Drivers> and remove them all (except for any logical printer drivers) .....

Or just do this.....

Hit Winkey+R, and paste the following.....

printui /s /t2

It will bring up the classic Drivers tab, familiar with XP. You can remove Drivers from there, after the printers are gone....

Then try and reinstall the network/local printers....
0
 

Author Comment

by:Seastang
ID: 36569784
Even with elevated rights after plugging in net start spooler I get access denied.
went to device manager and deleted the printer because Winkey+R  printui /s t2 got a pop up saying' properties can not be viewed' I have just found that the SDRSVS  has also failed.
0
 
LVL 3

Expert Comment

by:kinsey
ID: 36571002
Do you have a restore point prior to 9/12?
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 36571140
Did you mean the SDRSVC service?

Lets check Spooler for any dependencies (this way or the GUI, either way)....

start>cmd (elevated)

reg query "hklm\SYSTEM\CurrentControlSet\Services\Spooler" /v dependonservice

dependonservice     REG_MULTI_SZ    RPCSS\0\0

If we cannot use the native methods for removing the printer drivers, we can reference this site, which has a great step by step to remove them by hand.

How to clean up printer drivers
http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm

0
 

Author Comment

by:Seastang
ID: 36571222
Hi Johnb6767,Redrumkev, Kinsey:

Yes, there are several restore points over the past 2 weeks. I have ran Mal-warebytes, the Bit Defender Recovery disk anti-virus scan to Rule out any virus/mal-ware. I'm making a redundant back up copy of all Files, Folders, Docs  and a sys image to offsight storage. The plan is to run System File Checker from the CMD sfc /scannow. Doing a restore is an option, I'm considering but first   I want to find out what the cause is. The Sugestions and Help have been great and should have worked in most cases. The problem is deeper and I need to find the cause to keep it from happening on the other computers I maintain remotely  (they are all stand alone machines, with local printers  but preform simular function POS and includ XP, Vista and W7. So, far it hasn't shown up on any of the other machines. If there is any sugestions on how to proceed in tracking down the cause I am open to any. I'm in hopes that the SFC will fix and I can see what the diffrence is between the before and after in the logs of what happend.  

Thank you
Seastang
0
 
LVL 66

Accepted Solution

by:
johnb6767 earned 250 total points
ID: 36571236
Process Monitor might be a heavy hammer for this one, but it also might produce TOO much information, unless you are familiar with the Filtering.....

I think SFC is a good step.

Spooler Dependencies were ok?
0
 
LVL 3

Assisted Solution

by:kinsey
kinsey earned 250 total points
ID: 36571288

Have you Check the system log for ay disk errors?

likely you have filesystem or registry corruption.

This is what System Recovery is really for.

0
 

Author Comment

by:Seastang
ID: 36571290
Hi Johnb6767

 Yes, SDRSVC service it says fail error code 1813. Spooler got error code 2. Through the managment/services GUI I didn't try through the CMD.
I won't have remote access to the machine until tommorow early afternoon.
I tried to find the dependencies earlier for both services by the description says General internal error occured SYS cannot find file specified tried R click and then properties  and got this message properties cannot be viewed the local printspooler is not running pleas start the spooler or restart the machine. Tried both starting the service ( both the services ) and reboot  and couldn't start either of the services  
0
 

Author Comment

by:Seastang
ID: 36571385
Hi Kinsey,
Yea, thats what I'm thinking, I ran the Check Disk it didn't find any errors.

Johnb6767
I won't be able to check the dependancies through the CMD until tommorow.
Honestly, I'm not familiar with Filtering.

So, After checking the depends  run the SFC?
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 36578112
I would... If there are any other dependencies other than RPCSS, that might be your problem....
0
 

Expert Comment

by:Deepshinde123
ID: 36578212
Printer is on remote computer or you are mapping it from your local resources. If it is on remote computer then try to diable printer from local resources from Remote Desktop Connection Properties. May be your local printer driver is clashing the print spooler service.
0
 

Author Comment

by:Seastang
ID: 36578331
Sorry I haven't got back sooner,
Long day long story,lol
Nothing went right and didn't get to the computer. I wiil start tommrow
0
 

Author Closing Comment

by:Seastang
ID: 36937842
Ok, its 2 weeks later Thanks for all ideas and help. The problem with the print spooler not working and not being able to get it started wasn't solve. I was given the go ahead to pull, and scrub the machine, reinstall the o/s.
It's up and running. I'm sure on Monday the user will be glad she can now print.
Thanx for the sugestions

Seastang
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
The viewer will learn how to use the =DISCRINV command to create a discrete random variable, use this command to model a set of probabilities and outcomes in a Monte Carlo simulation, and learn how to find the standard deviation of a set of probabil…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question