Solved

Forwarding ports on ASA5510

Posted on 2011-09-19
42
5,028 Views
Last Modified: 2012-05-12
For the life of me I cannot seem to get this to work. I am working on a new (used) asa5510 with image 8.41 and asdm 6.41.  I am trying to forward RDP to my internal server but every time I add the NAT rule, This is the error I get: nat (Outside,Outside) 2 source static any any destination static interface Netserv1 service RemoteDesktop RemoteDesktop unidirectional
       NAT unable to reserve ports.

I have made this work with an ASA5505 but I seem to be stumped as to why it won't work on this device. Here is the config:
ASA Version 8.4(1)
!
hostname netasa1
domain-name  testing.com
enable password 2KFQnsdbNIdI.2KYOU encrypted
passwd 2KFQnbNdsIdI.2KYOU encrypted
names
dns-guard
!
interface Ethernet0/0
 nameif Outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/1
 nameif Inside
 security-level 90
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 10.1.2.1 255.255.255.0
 management-only
!
boot system disk0:/asa841-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup Outside
dns server-group DefaultDNS
 domain-name testing.com
object network Netserv1
 host 10.1.1.3
object service RemoteDesktop
 service tcp source range 1 65535 destination eq 3389
object network Inside_Network
 subnet 10.1.1.0 255.255.255.0
object-group service RDP tcp
 description Remote Desktop Protocol
 port-object eq 3389
access-list Outside_access_in remark Incoming Remote Desktop Clients
access-list Outside_access_in extended permit tcp any interface Outside object-group RDP
pager lines 24
logging enable
logging asdm informational
mtu Outside 1500
mtu Inside 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-641.bin
no asdm history enable
arp timeout 14400
nat (any,Outside) source dynamic any interface
access-group Outside_access_in in interface Outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.1.2.0 255.255.255.0 management
http 10.1.1.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.1.1.31-10.1.1.50 Inside
dhcpd dns 10.1.1.3 4.2.2.2 interface Inside
dhcpd lease 86400 interface Inside
dhcpd domain minettech.com interface Inside
dhcpd update dns both override interface Inside
dhcpd enable Inside
!
dhcpd address 10.1.2.2-10.1.2.254 management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:6a1b318d6851ds5a38ab90d28dab40928b
: end

Any help is greatly appreciated.  Thank you.
0
Comment
Question by:Sminster
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 15
  • 15
  • 11
  • +1
42 Comments
 
LVL 5

Expert Comment

by:Alexey Komarov
ID: 36564957
Use
static (inside, outside) tcp interface 3389 10.1.1.3 255.255.255.255 3389
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36565186
Use

object network Netserv1
 static (inside, outside) static interface service tcp 3389 3389
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36565188
Alexey's suggestion works only with pre8.3 IOS
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36565218
@fgasimzade: almost ;)

object network Netserv1
Host 10.1.1.x
 static (inside, outside) static interface service tcp 3389 3389

Access list should be:
access-list Outside_access_in extended permit tcp any host 10.1.1.x object-group RDP
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36565226
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36565259
@erniebeek,

Thanks!
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36565322
my pleasure :)
0
 

Author Comment

by:Sminster
ID: 36566405
Sorry guys, this is what I  get when entering that command:

static (inside, outside) static interface service tcp 3389 3389
                     ^
ERROR: % Invalid input detected at '^' marker.
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36566417
Try Outside first. If does not work for you, enter ? after inside, see what it gives you
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36566432
No spaces ;)

And we also are still getting used to the new syntax :-~
It should be:
object network Netserv1
Host 10.1.1.x
Nat (inside,outside) static interface service tcp 3389 3389
0
 

Author Comment

by:Sminster
ID: 36566461
even from the first entry "static" it is showing "unrecognized command"  I had some issues getting this device to pass power-on tests. eventually it powered on but is it possible its not loading some commands? Seems like if it powered up successfully, everything should be working okay
0
 

Author Comment

by:Sminster
ID: 36566477
Result of the command: "object network Netserv1"

The command has been sent to the device


Result of the command: "Host 10.1.1.3"

The command has been sent to the device


Result of the command: "Nat (inside,outside) static interface service tcp 3389 3389"

ERROR: NAT unable to reserve ports.
0
 

Author Comment

by:Sminster
ID: 36566489
seems syntax is now correct but now we are back to the original error

Thank you for all your help so far it is appreciated.
0
 

Author Comment

by:Sminster
ID: 36566499
netasa1(config)# Nat (inside,outside) static interface service tcp 3389 3389
                                                             ^
ERROR: % Invalid input detected at '^' marker.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36566500
Looks like something is already reserved.
Could you play your config again?
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36566525
On discard that.
Your interfaces are written with uppercase, so you need to do that everywhere (its cases sensitive).
0
 

Author Comment

by:Sminster
ID: 36566530
netasa1(config)# sh run
: Saved
:
ASA Version 8.4(1)
!
hostname netasa1
domain-name testing.com
enable password 2KFQnbvnnNIdI.m2KYOU encrypted
passwd 2KFQnbNIdI.cxx2KYOU encrypted
names
dns-guard
!
interface Ethernet0/0
 nameif Outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/1
 nameif Inside
 security-level 90
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 10.1.2.1 255.255.255.0
 management-only
!
boot system disk0:/asa841-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup Outside
dns server-group DefaultDNS
 domain-name testing.com
object network Netserv1
 host 10.1.1.3
object service RemoteDesktop
 service tcp source range 1 65535 destination eq 3389
object network Inside_Network
 subnet 10.1.1.0 255.255.255.0
object-group service RDP tcp
 description Remote Desktop Protocol
 port-object eq 3389
access-list Outside_access_in remark Incoming Remote Desktop Clients
access-list Outside_access_in extended permit tcp any interface Outside object-group RDP
pager lines 24
logging enable
logging asdm informational
mtu Outside 1500
mtu Inside 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-641.bin
no asdm history enable
arp timeout 14400
nat (any,Outside) source dynamic any interface
access-group Outside_access_in in interface Outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.1.2.0 255.255.255.0 management
http 10.1.1.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.1.1.31-10.1.1.50 Inside
dhcpd dns 10.1.1.3 4.2.2.2 interface Inside
dhcpd lease 86400 interface Inside
dhcpd domain minettech.com interface Inside
dhcpd update dns both override interface Inside
dhcpd enable Inside
!
dhcpd address 10.1.2.2-10.1.2.254 management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:6a1b318d68gs515a38adsb90d28dab40928b
: end
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36566548
Seems like this statement does not allow you to add static NAT.

nat (any,Outside) source dynamic any interface

Can you try removing it and adding our previously suggested static NAT
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36566568
I think you overlooked my post about the uppercase:)
nat (Inside,Outside) static interface service tcp 3389 3389

Look at the interface names.
0
 

Author Comment

by:Sminster
ID: 36566594
netasa1(config)#  Nat (Inside,Outside) 1 source static interface tcp service 3389 3389

ERROR: interface doesn't match an existing object or object-group
0
 

Author Comment

by:Sminster
ID: 36566611
Thank you for your help, I am late for a meeting. I will resume after the meeting
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36566653
Ok, something did you to do when get back:

object network Netserv1
host 10.1.1.3
nat (Inside,Outside) static interface service tcp 3389 3389

These three should do it ( including uppercase).
Oh, and don't forget the access list.
0
 

Author Comment

by:Sminster
ID: 36566676
I will try that when I get back, thanks again
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36566706
erniebeek, dont you think this statement causes the error?

nat (any,Outside) source dynamic any interface
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36566735
I personally don't think so, that should be the equivalent of the Nat (xx) 1 0.0.0.0 0.0.0.0 and global (outside) 1 interface statements.
There is a slim chance that it might interfere with the pat we're making, but we'll address that when we run in to it.
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36566768
Well, 8.3 dynamic NAT should look like this, no?

object network obj-192.168.1.0
   subnet 192.168.1.0 255.255.255.0
   nat (inside,outside) dynamic interface
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36566815
In that case you only nat the inside interface to the outside.
So guess what any does...................

;)
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36568202
I though dynamic NAT in 8.3 version should be configured under object network... not like Sminster configured
0
 

Author Comment

by:Sminster
ID: 36568250
Fgasimzade I believe you are correct. I do recall it being different on my 5505 which I do not have in service any longer (but was using the same IOS version).
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36568263
Can you try removing that statement and adding

object network Netserv1
host 10.1.1.3
nat (Inside,Outside) static interface service tcp 3389 3389
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36568589
We already have that covered, look up some posts ;)
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36568715
@Smister: that could very well be possible. By default everything is natted to the outside. Normally you just want your specific subnets natted (like the old config). And sometimes such all nat can overrule any rules you put in after that.

But first, let's set up the portforwarding right :)
0
 

Author Comment

by:Sminster
ID: 36570067
Okay I have removed the controversial " any any" Nat rule and edited the network object "inside_network" to be pat on the outside interface. Tried sending the rdp Nat rule again and it said "Nat cannot reserve ports"
0
 

Author Comment

by:Sminster
ID: 36570471
I tried this:
Nat (Inside,Outside) source static Netserv1 interface service RemoteDesktop RemoteDesktop

and it resulted in  ERROR: NAT unable to reserve ports.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36572062
Hm,

Could you post your config again to see what it looks like now?
0
 

Author Comment

by:Sminster
ID: 36573564
netasa1(config-network-object)# sh run
: Saved
:
ASA Version 8.4(1)
!
hostname netasa1
domain-name testing.com
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
dns-guard
!
interface Ethernet0/0
 nameif Outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/1
 nameif Inside
 security-level 90
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 10.1.2.1 255.255.255.0
 management-only
!
boot system disk0:/asa841-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup Outside
dns server-group DefaultDNS
 domain-name testing.com
object network Netserv1
 host 10.1.1.3
object service RemoteDesktop
 service tcp source range 1 65535 destination eq 3389
object network Inside_Network
 subnet 10.1.1.0 255.255.255.0
object service RDS
 service tcp source eq 3389 destination eq 3389
object-group service RDP tcp
 description Remote Desktop Protocol
 port-object eq 3389
access-list Outside_access_in remark Incoming Remote Desktop Clients
access-list Outside_access_in extended permit tcp any interface Outside object-group RDP
pager lines 24
logging enable
logging asdm informational
mtu Outside 1500
mtu Inside 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-641.bin
no asdm history enable
arp timeout 14400
!
object network Inside_Network
 nat (any,Outside) dynamic interface
access-group Outside_access_in in interface Outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.1.2.0 255.255.255.0 management
http 10.1.1.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.1.1.31-10.1.1.50 Inside
dhcpd dns 10.1.1.3 4.2.2.2 interface Inside
dhcpd lease 86400 interface Inside
dhcpd domain testing.com interface Inside
dhcpd update dns both override interface Inside
dhcpd enable Inside
!
dhcpd address 10.1.2.2-10.1.2.254 management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:c751cb53265baccacef40fc8acec7021
: end
0
 
LVL 18

Assisted Solution

by:fgasimzade
fgasimzade earned 200 total points
ID: 36573739
Have you try reloading ASA? :)
0
 

Author Comment

by:Sminster
ID: 36573783
No I have not tried that yet. Will give it a shot
0
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 300 total points
ID: 36573790
Let's try the following:

object network Inside_Network
no nat (any,Outside) dynamic interface
nat (Inside,Outside) dynamic interface
clear xlate
object network Netserv1
nat (Inside,Outside) static interface service tcp 3389 3389
0
 

Author Closing Comment

by:Sminster
ID: 36578691
fgasimzade, erniebeek,
Thank you so much for all of your time invested in this solution. I can't say as to which task was the overall fix because I did both actions at the same time and for the time each of you have put in, you both deserve 100 times the points available to give. I am gratefull there are people like you out there for people like me to learn from. Have a great day and thank you again for your help!
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 36578699
Good luck! :)
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36579710
The pleasure was all ours :)
Have a great day there too and until we meet again.
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

689 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question