Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Slow responce of Linux serven inside local network

Posted on 2011-09-20
2
Medium Priority
?
434 Views
Last Modified: 2012-05-12
Hello Experts,

I have some strange problem (probably DNS) inside my local network in office.
We have,
VMWARE XSI server running 2 virtual servers right now, Ubuntu server (For apache web server) and windows 2008 Srv as DC. My problem is strange, when i'm trying to access ubuntu via SSH  or any other protocol from local network, response from server can take up to 10 seconds,
But when i'm trying to access websites stored on this server there is no delay at all.

We have Fortigate 50b appliance as IPS and router in our local net. It is DHCP server as well.

Please assist.  
0
Comment
Question by:DanSmir
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
2 Comments
 

Accepted Solution

by:
DanSmir earned 0 total points
ID: 36567423
Solved
1. It seems like a reverse DNS problem. By default, SSH will check where incoming connections are from by performing a reverse DNS query on the incoming IP address. This will work fine when you come from an external computer, but might fail when you come locally if you don't have DNS setup properly. If you haven't done so already, you could try to add all your computer's hostnames and IP address in /etc/hosts on all computers (especially the ssh server) to make sure the reverse DNS will succeed. Obviously, you'd need to use static IP addresses on your LAN for that to work.

2. Failing the /etc/hosts solution above, you could try setting the UseDNS setting to 'no' in the ssh server. To do this:

Code:

sudo nano /etc/ssh/sshd_config

add this line to the bottom (or change the 'yes' to 'no' if it's already in the config file):

Code:

UseDNS no

then restart the ssh server:

Code:

sudo /etc/init.d/ssh restart

0
 

Author Closing Comment

by:DanSmir
ID: 36567426
I found solution my self, and posted here. Please close this question
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question