ODBC RDB 2.10.11 Cant be installed on Server 2003

I cannot install ODBC RDB Driver for oracle on server 2003.  I get two error codes, one is for the wrong path given into the installation path (cant be set to root of c: drive) and the other error message is for a registry problem, more specifically:

NT.STP(917): The Specified Registry File is Invalid.

Are there any work around for this one?  I need to geth this version of ODBC RDB Driver installed on a web server in order to facilitate communications with a new project due YESTERDAY.  

Please advise.  
RDB.jpg
ripplestAsked:
Who is Participating?
 
ripplestConnect With a Mentor Author Commented:
Thanks for all the added notes regarding my issue.  After longing to find the solution, and through a bit of troubleshooting of my own we found the user installed a later version of the RDB driver and wanted to install teh earlier version on top of it.  This created problems.  We had to remove the later version, remove all registry entries for that later version, and then install the old version, 2.10.11, then install teh version 3.x.x.  This seemed to work as we are now up and running with two rdb driver versions running on 2 server 2003 boxes.  

I appreciate everyones insight and trouble they went through to get our company's resources up and running again.  
0
 
slightwv (䄆 Netminder) Commented:
Never installed RDB but since you mention the urgency I thought I would post.

I typically see that type of error message when I'm not running the install as a Local Admin of the server.
0
 
ripplestAuthor Commented:
I will try that now, as this is an urgent one.  
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
Amitabh SinghAWS Certified Solution Architect | L3 IT Specialist for CloudCommented:
Hi have a look to the EE Article below , This user have same problem like you but on windows 2000 may be its same problem for you also !

this user resolved his problem by

Unset the environment variable for ORACLE_HOME and
restart the machine

http://www.experts-exchange.com/Database/Oracle/Q_21055388.html
0
 
slightwv (䄆 Netminder) Commented:
>>Hi have a look to the EE Article below

I would probably not put a lot of faith in that link.  The Oracle software referenced there is VERY old and since the question was actually forced closed by Moderators, there is no way of knowing if they actually helped to resolve the problem.
0
 
ripplestAuthor Commented:
Install under LOCAL ADMINISTRATOR with ADMIN rights did NOT work.  Same error message.  I guess so far im left with the environment variable fix.  I will try that next.  
0
 
slightwv (䄆 Netminder) Commented:
I was trying to research this a little more and saw what looks like a "2000" in the image you uploaded.

I also went out to Oracle Support to look at the certifications and it appears that ODBC RDB 2.10.11 is no longer supported.

The oldest version I can locate is 3.3.1 and that only shows HP OpenVMS as supported.

You might not be able to install that old of software on Windows 2003.
0
 
ripplestAuthor Commented:
Environment variable ORACLE_HOME is not listed under advanced settings --> environment variables.  We do have this installed on a server that had a mirror image installed on it as well.  The image installed on both servers was identical.  Of course since the image was installed, both machines have had various user profiles created, and various software packages installed.  

Since the error message relates to the registry, but because the driver is so old, i am leading to believe this issue is going to have to be fixed at the regedit level.  

One thing we also tried was to export the ODBC registry keys, delete the original keys from regedit, try to reinstall the RDB driver 2.10.11, but when it still failed i reimported the registry keys.  

Please let me know if anything else comes to mind.  We cannot reimage this server as it is in production and provides Timken with operational advatages for our steel industry.  It must also stay up, but if you absolutely need us to reboot the web01, we can post a news item and prepare and fair warn the audience of a planned maintenance procedure.  
0
 
Amitabh SinghAWS Certified Solution Architect | L3 IT Specialist for CloudCommented:
ripplest i found this release notes for Rdb Version 2.10.11and looks like this application not made to work on  Windows 2003 as you can find in

1. Installation

      Oracle installer installs the Oracle ODBC Driver for Rdb
      software for the MS Windows, Windows NT and Windows 95
      operating systems.      The 16-bit driver may be installed under
      Microsoft Windows, Microsoft Windows NT or Microsoft Windows 95.
      The 32-bit driver can only be installed under Microsoft Windows NT
      and Microsoft Windows 95
.  Refer to the Oracle ODBC Driver for Rdb
      help file section entitled Post-Installation information for a list
      of files installed on your system. Refer to README.TXT enclosed in
      your software distribution kit for additional installation information.

Oracle ODBC Driver for Rdb Version 2.10.11 Release Notes
http://76.89.205.34:8080/softwares/OLD%20STUFF/Od_rdb30/WIN95/ODBC16/SQRDB.TXT


did you try to run setup by Windows NT compatibility mode if not then try this ?

Go to Rdb setup folder , right click on setup file  (not sure about name it can be : setup.exe or setup.msi ) choose properties > click on compatibility tab and select Windows NT in the list > apply > ok and then try to run setup again  .

 run a application in Windows NT compatblity mode
0
 
ripplestAuthor Commented:
our IT dept ultimately found the solution for this one.
0
 
ripplestAuthor Commented:
thanks to all.  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.