Solved

HP ProLiant DL360 G4 will not boot HP Smartstart 8.70 from USB key

Posted on 2011-09-20
12
5,019 Views
Last Modified: 2012-12-07
I am trying to reinstall an HP ProLiant DL360 G4, with HP Smartstart 8.70. There is someking of problem with the ILO that i cannot access to it (the "press F8 to enter ILO" message  does not appear during initial boot posts and, as the server did not come with DVD, i am trying to use the USB feature.

I downloaded and used successfully the HP USB key utility to create the usb boot with Smartstart 64bits.

The server boots fine with the USB key and the smartstart starts running but suddenly stops. I hit the ESC key and see the linux boot messages. The ones that catch my attention are:

"Fatal Error"
"No screens found"

Can anyone help me?

Best Regards
Marco Rodrigues
0
Comment
Question by:isvouga
  • 4
  • 2
  • 2
  • +4
12 Comments
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36567041
I would try downloading the USB key software and trying it again.  I'd use a different USB key if possible.

I would also confirm that the software you downloaded is for the hardware you own.  Focus on compatibility with the video chip.

No screens found sounds like X is unable to find working settings for your video chip.

Look at the documentation to see if you can modify the USB key configuration to use VESA mode for X.  The resolution won't be great but once you get a screen, you should be able to do some work.
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 36567070
Have you looked in the BIOS (F10) setup screens to see if there's an option to show F8 and other prompts? I seem to recall on some 360's you could supress them?

That might give you iLO access again.
0
 
LVL 3

Expert Comment

by:RitBit
ID: 36567428
It seems seems like the ilo is not running at all.. (hence the prompt is not showing up)
Have you tried reflashing the ilo rom? You can get the firmware CD's from HP for free.

You don' t have to look in to the bios.. the ilo config is not there...
Actually it runs complete stand alone of the rest of the system. It only responds to a call on the bus (INT19, like a SCSI or network card) to show a message.


0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36567608
Tony & RitBit, Marco reports getting the Linux boot log.  The error he's getting is most likely from the Xorg server software.  When I've seen the error, it's due to attempting to set a resolution and rates that aren't supported by the h/w.

Of course, I could be wrong.
0
 
LVL 3

Expert Comment

by:RitBit
ID: 36567792
Dear hmccurdy...
Will all respect: It seems you are not familiar with the HP Proliant DL360 G4 hardware.
He is not complaining about an X11 problem, but the built in IP-KVM solution of the server (name iLO). This has absolutely nothing to do with any OS but the build in features of this server. The firmware update solution runs on linux and uses X11 and indeed produces an error but the fact that that one doesn't work properly is not his main problem. It's another issue he is facing.

isvouga:
Do you have an OS running on the system? Most firmware you can install from linux. You only need to identify the correct file from the CD. I'm happy to help you with that.
Have you tried bootig from a CD as well, maybe there is something wrong with the files on the stick. You can try to download the software ( check Md5!) ) and reflash the USB stick once more.

0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36567893
Fair enough RitBit.  Is the "no screens found" the reason he's trying to do the rescue?  Sounds to me that "the server boots fine" is what confused me.  

I agree with reflashing the USB key.

A question for the author -- do they offer a CD image that will boot to the USB key?  I have a system that I build (for customers) on a usb key.  Some computers have trouble booting directly to a USB key so I also make a CD that can be used to reboot to the USB key.  If I found a need to do that, perhaps HP did too.  (Or perhaps they didn't).  Occurs to me that is something to investigate if the USB key won't boot after reflashing.
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 

Author Comment

by:isvouga
ID: 36567958
Well, yes...

In fact i face two problems:
1. ILO not working
2. Cannot start Smartstart

I only face the 2nd problem because i cannot solve the first one.
The USB key is fine. I recreated it with HP USB Key Utility and tried again
Tried the HP Smart Update Firmware but it won't reflash the ILO Rom because it is already in the last version.
Yes, the server has an Operating system working (Win2k8), but tools for accessing ILO do not respond.
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36568053
I'll tell you what I'd try with "no screens" assuming I'm right about it being X.  I don't know if this is really a good idea but it's what I'd try.  RitBit is right in that I don't know about that specific server.  I have had numerous battles with X.  OK, with the caveat stated...

I would get a LiveCD version of Linux (or a different USB version of Linux).  I'd boot to that and then mount the partition and go into inittab and change the runlevel to boot to the command prompt instead of right into X.

I'll go look that up if you don't know how to do that.  (I'd say right now but I'm on a Windows box ATM and don't currently have a Linux box handy.)

Again, don't know if this is a wise approach on that computer.  I can say, if this was my problem, I'd try it wise or foolish.
0
 
LVL 55

Expert Comment

by:andyalder
ID: 36568652
I'd go with hmccurdy's suggestion of trying a different USB key, I've gone through many USB keys trying to get SmartStart (and the firmware DVD) to work reliably. Some makes aren't bootable, some half load and hang with some meaningless Linux message (presumably like this case) and some work all the time. If I could buy a key marked "guaranteed to work with SmartStart" I'd pay double price for it and buy 10 while I was about it.
0
 
LVL 9

Accepted Solution

by:
ghodder earned 125 total points
ID: 36570656
The last version of SmartStart which officially supported the DL360 G4 was 8.30. Support was removed in 8.40 according to the 8.40 release notes and Hardware Support List. That is probably why it isn't working properly for you.

You can download 8.30 from HP - x64 or x86. I would try either of those before thinking there's something wrong with the USB key.
0
 

Author Closing Comment

by:isvouga
ID: 36597952
The ILO problem was not solved as it seems to be an hardware problem.
0
 

Expert Comment

by:tricom2007
ID: 38671664
Thanks Ghodder using the correct release of Smartstart resolves this issue. HP G4 servers are not supported past 8.3. You must use 8.3 to install Windows 2008r2 on a G4 server
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Why Is My Script Not Running at Login for Users? 8 31
server plus 2 47
What is this Task? 4 42
nagios remote hosts 9 15
this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now