• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1149
  • Last Modified:

GP/Dynamics as Remote App on Terminal Server - Re-establishing disconnected sessions?

We have GP/Dynamics 10 deployed as a remote app available via MSI or remote web access.

Users in a remote office that are connected via an unreliable point-to-point VPN tunnel have had issues in the past where if the tunnel drops, their GP session closes and anything they were working on (say entering journal entries pre-batch).

I set the terminal server to not end a disconnected session and set idle and disconnected timers to none. However now we have users that when launching GP, receive multiple instances of GP opening (all the previous disconnected sessions).

Is there a way to re-establish a connection to a disconnected session, without having a new instance of GP opened?
0
Tercestisi
Asked:
Tercestisi
  • 4
  • 3
1 Solution
 
Abdulmalek_HamshoCommented:
Have you enabled "Restrict Remote Desktop users to a single Remote Desktop Services Session"?
0
 
TercestisiAuthor Commented:
Yes, it is set to restrict each user to a single session as that is the default setting.

Under user logon mode I have allow all connections selected, but there is an option there for "Allow reconnections, but prevent new logons?"
0
 
Abdulmalek_HamshoCommented:
Can you post your Group Policy' settings for the terminal services?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
TercestisiAuthor Commented:
I have no group policy settings for the terminal services set; I had at one time but instead just configured it locally last time I made changes and reset all group policy settings to Not Enabled.
0
 
Abdulmalek_HamshoCommented:
When you configure your Group Policy to Enable or Disable some policies, putting "Not Configured" back won't revert the policy to its default state.

Please ensure enabling the followings:

1- "Automatic Reconnection"
2- "Configure Keep-alive connection interval" = 1
3- "Restrict Remote Desktop users to a single Remote Desktop Services Session"

And revert the rest of related policies to its default state.
0
 
TercestisiAuthor Commented:
Done; I will test those settings out but that looks to be what I needed.

Would I still set end a disconnected session to never, as well as having no active session or idle session time limits?
0
 
Abdulmalek_HamshoCommented:
Yes, keep it "Never".
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now