Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1709
  • Last Modified:

SQL Server 2008 R2 SA Password

I just finished installing Small Business Server 2011, and I'm trying to login to the local database using windows authentication and it won't work. Does anyone know how to enable the SA account or what I should be using to login using the management studio?
0
fluk3d
Asked:
fluk3d
  • 5
  • 4
1 Solution
 
venk_rCommented:
May be the windows user doesnt have a local admin rights.if your'e in a domain then check the domain user permissions.
if neither doesnt work  reinstall with mixed mode authentication and will be able to connect with a valid login.
0
 
fluk3dAuthor Commented:
I'm logged in with a user that has domain admin, enterprise admin, schema admin permissions. I'd rather not reinstall as sharepoint, and other services are using the instance
0
 
venk_rCommented:
There is a new feature in Windows Server 2008 called User Account Control (UAC).  This feature causes a user, whether administrator or not, to provide credentials when opening applications that may affect the system as a whole.  A possible reason your administrative login is not working to login to the SQL Server is because you are not opening SQL Server Management Studio as administrator.  To get around this you will need to right click on SQL Server Management Studio and select "Run as administrator" each time you open the application.  After doing so, you should be able to use Windows Authentication to login to the SQL instance.

UAC settings can be adjusted, or even completely disabled, if you feel that it is not needed.  You can read more about Windows Server 2008 and UAC here: http://technet.microsoft.com/en-us/library/cc772207.aspx.

0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
fluk3dAuthor Commented:
UAC is disabled on the server, and tried it again with right click as admin and I still get the same error.

I just looked through the services, and noticed there are instances installed for sharepoint etc.. however; I  don't see a default instance which I can connect to. Do I need to install another instance using SQL Server 2008 R2 express, and manage it that way?


If someone has some SBS 2008/2011 experience with SQL that would be great
0
 
venk_rCommented:
One more thing. Is your domain admin user added as Local admin?
0
 
fluk3dAuthor Commented:
SBS is a domain controller, so there is no local admin
0
 
venk_rCommented:
When you installed SQL Server Did you install named or default instance?
0
 
marcustechCommented:
Which database are you trying to log into?
0
 
fluk3dAuthor Commented:
Fixed - reinstalled SQL with a new instance
0
 
fluk3dAuthor Commented:
I answered my own question
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now