js back button problem

On this page i am building a user comment system.

However, the js works good when load the page originally, but when i click to another website and then use the back button the thing gets all messed up.

What do i need to put in the js to get it to work on back button visit?
blink10Asked:
Who is Participating?
 
Gurvinder Pal SinghConnect With a Mentor Commented:
right click, inspect element, there you can see multiple options
0
 
Gurvinder Pal SinghCommented:
<< thing gets all messed up.>>
You need to elaborate a bit more

If this is happening for ff, the check this one
http://stackoverflow.com/questions/2638292/after-travelling-back-in-firefox-history-javascript-wont-run
0
 
blink10Author Commented:
ok the function i wrote should do the following....

When click, change the dimensions of the textarea and drop the faded message.

When i use back button, i get the text that is suppose to be faded as normal text, and none of the other fucntions will work. This is in chrome.

This is not a reloading problem as ur link deals with, this a is a back button issue.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
Gurvinder Pal SinghCommented:
it could well be a reloading problem, since your browser is not sure whether or not to capture onload event or not
0
 
blink10Author Commented:
i added the code from stack, no luck, yes it does seem to be loading again i guess, but i doesnt fix it
0
 
Gurvinder Pal SinghCommented:
please check in you debugger (chrome has a good one),
-- if the scripts are getting loaded or not
-- use breakpoints and console.logs to see if control flow is going as expected.

Please isolate the problem and reach to the specific one
0
 
blink10Author Commented:
do you have tutorial on this? I have never troubleshoted with chrome before
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.