Network browsing in Server 2008 Remote Desktop under Server 2003 domain with GPO

Active Directory Windows 2003 Domain
Have a member virtual server running server 2008
Remote Desktop users connect to the server 2008 (these are high school students)
I need to restrict the students from being able to click on "network" and see a view of all the computers in the network. When you click on "documents" the "network" link is listed on the left no matter one. Network places is gone via GPO.
GPO is in AD on the 2003 server, but I can't get this server 2008 from advertising the network.
Here are some options that I've read and have tried but they do not work either:
No "Entire Network" in my network places
AND
No "Computers near me" in My Network Places
Also created a registry entry:
Hive: HKEY_CURRENT_USER
Key: Software\Microsoft\Windows\CurrentVersion\Policies\Network
Name: NoEntireNetwork
Type: REG_DWORD
Value: 1
Thank you Experts for your help in this.
j_creech72Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
j_creech72Connect With a Mentor Author Commented:
The netbios over tcp/ip did take out some of the computers but still shows my windows 7 machine. I ended up using yo bee's suggestion in creating a key in the NonEnum for the {F02C1A0D-BE21-4350-88B0-7367FC96EF3C} and that worked the best. I want to thank you both for responding so quickly and helping me out with this!
0
 
ashutoshsapreCommented:
In the TCP/IP Properties of the network, select the "Disable NetBIOS over TCP/IP" option in the WINS tab. Also, stop and disable the "Computer Browser" service.
0
 
yo_beeDirector of ITCommented:
Here is a registry setting the will remove the Network Icon from Windows Explorer

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\NonEnum\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}]=dword:00000001
0
 
j_creech72Author Commented:
FYI with regards to this {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}]= key addition, there was a website that also suggested something similar but it was by creating a group policy .adm file. If you google it, it might help you too but for what I was doing, I just put this entry in manually as my solution expert suggested.
0
All Courses

From novice to tech pro — start learning today.