Solved

Help Troubleshooting RPC over HTTP

Posted on 2011-09-20
3
601 Views
Last Modified: 2012-05-12
I just setup an exchange 2010 server in this configuration:
Windows 2008 R2 with Hyper V Role, AD and Exchange 2010 sp1 rollout 5.
All the exchange features such as Outlook, OWA, Activesync work except for RPC over HTTP.  

When I run the Remote Connectivity Analyzer I get these results when having "use autodiscover" turned on:      Testing RPC/HTTP connectivity.
       The RPC/HTTP test failed.
       
      Test Steps
       
      ExRCA is attempting to test Autodiscover for tflomer@flomer.com.
       Testing Autodiscover failed.
       
      Test Steps
       
      Attempting each method of contacting the Autodiscover service.
       The Autodiscover service couldn't be contacted successfully by any method.
       
      Test Steps
       
      Attempting to test potential Autodiscover URL https://flomer.com/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
      Attempting to test potential Autodiscover URL https://autodiscover.flomer.com/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
      Attempting to contact the Autodiscover service using the HTTP redirect method.
       The attempt to contact Autodiscover using the HTTP Redirect method failed.
       
      Test Steps
      Attempting to contact the Autodiscover service using the DNS SRV redirect method.
       ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
       
When I put in my info manually I get this error:
      Testing RPC/HTTP connectivity.
       The RPC/HTTP test failed.
       
      Test Steps
       
      Attempting to resolve the host name exchange.flomer.com in DNS.
       The host name resolved successfully.
       
      Additional Details
      Testing TCP port 443 on host exchange.flomer.com to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The certificate passed all validation requirements.
       
      Test Steps
      Checking the IIS configuration for client certificate authentication.
       Client certificate authentication wasn't detected.
       
      Additional Details
      Testing HTTP Authentication Methods for URL https://exchange.flomer.com/rpc/rpcproxy.dll.
       The HTTP authentication methods are correct.
       
      Additional Details
      Testing SSL mutual authentication with the RPC proxy server.
       Mutual authentication was verified successfully.
       
      Additional Details
      Attempting to ping RPC proxy exchange.flomer.com.
       RPC Proxy was pinged successfully.
       
      Additional Details
      Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server exchange.flomer.com.
       The attempt to ping the endpoint failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.

I've tried disabling the firewall on the server (did not have any impact).  I don't really know what else to try.  Any suggestions?
0
Comment
Question by:Mauka
  • 2
3 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36571969
Have you bought a 3rd party SSL certificate with the following names in it:

mail.externaldomain.com (or whatever you chose to use)
autodiscover.externaldomain.com
internalservername.internaldomain.local
internalservername

Did you then import and enable the certificate within Exchange?

Have you created an Autodiscover A record pointing to the IP Address of your Exchange 2010 server in External DNS (not internal)?

If not - then please do as this will solve your problems right away.
0
 

Accepted Solution

by:
Mauka earned 0 total points
ID: 36574260
OK.. after hours and hours of trying to troubleshoot this, I finally realized my dumb mistake.  I forgot to turn on "outlook anywhere".  keep forgetting about needing to turn this on manually as to me it should be automatic when you turn on the RPC to HTTP feature....

Thank you anyway.
0
 

Author Closing Comment

by:Mauka
ID: 36597748
When enabling RPC over http you also need to make sure the "Outlook Anywhere" feature is turned on Under the Server Client Access.  It is not turned on automatically.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question