• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1121
  • Last Modified:

Truncate the body of an Announcement in SharePoint 2007

All,
I would like to truncate the body of text in the standard Announcement List that comes out of the box.

So far I have yet to figure out a solution.  Any feedback is very much appreciated!
0
erobles1963
Asked:
erobles1963
  • 6
  • 5
2 Solutions
 
svetayeCommented:
Hello,
You can accomplish this using some JavaScript or using DataView Web part (the preffered option).
Please reade more about the DataView option here:
http://www.dlocc.com/articles/sharepoint-data-view-web-part-announcements-list/

In case you are using a DataView you can use the "substring" XSLT function on your item body.
It will look like this:
<xsl:value-of select="substring({@Body},50)" />"

It will truncate the "Body" field content to 50 characters.
0
 
erobles1963Author Commented:
Svetaye,

I've tried your recommendation but I'm not able to achieve the end results I'm looking for -- here is the actual code I am using:

<xsl:value-of disable-output-escaping="yes" select="substring((@Body),50)" /></div></TD>

v/r
Ernest
0
 
svetayeCommented:
Does any part of the "Body" field content appears on the page?
Please try this code:
<xsl:value-of disable-output-escaping="yes" select="substring({@Body},0,50)" /></div></TD>


0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
erobles1963Author Commented:
svetaye,

I added the code as you asked and when I refreshed the page the "body" of all announcements were not shown.

I'm confused...

v/r/
Ernest
0
 
svetayeCommented:
Ok,
Maybe your "body" column has another internal name?
Let's try to do it using the wizard.
On the right side of the screen you shoud see the "Data Source" toolbar (if you didn't close it). There you can see all list columns of the list. Did you see the "Body" column there?

If so please drag this column to your data view on the page. It will place the code that you need to display the body. Something like this: <xsl:value-of select="@FieldName" disable-output-escaping="yes"/>
There you will see the internal name of the "Body" column.

Delete the "@FieldName" include quotes and type double quote again - the auto complete will show up.
Click on the Expression builder and use the wizard to complete the code.

A few SharePoint XSLT tips here:
http://fuchangmiao.blogspot.com/2008/05/sharepoint-xslt-tips.html
0
 
erobles1963Author Commented:
Strange,

Here is what I get:

SharePoint Designer cannot render the XSLT in this Data View...

Failed seting processor stylesheet: 0x80004005: Expression expected.substring(-->{<--@Body},0,50)

Here is the code:

<TD Class="{$IDAFOBQG)"><div dir="{ddwrt:GetVar('Direction'))"><xsl:value-of disable-output-escaping="yes" select="substring({@Body}),0,50)" /></div></TD>
0
 
svetayeCommented:
Please try to remove {} brackets from the {@Body} .
0
 
erobles1963Author Commented:
Svetaye:

When I remove the brackets and view there is no body content...it removes the content of the body.

This is so strange, as I did not think truncating could be so difficult in SharePoint.

Phil
0
 
svetayeCommented:
I can see only one reason for this empty "Body" issue : you are using "Enhanced Rich Text" mode of the column. In this case you can't actually know how many characters you'l have in this field because Enhanced rich text field always add ome HTML to the content.

So try to set substring limit to some big number like 600 and check the content. if you see the result you have two options: use some big number as a limitation like 250 chars instead of 50 but it never will be exact the same number of characters (you don't know how many HTML characters every field contains) or you can change the column settings in the list settings and set it to "Plain Text". Plain text will contains only the text content without pictures'tables or any styles inside. Plane text you can truncate to 50 characters witout any issues.
0
 
erobles1963Author Commented:
svetaye,

I will revisit this issue today.  I hope your guidance and potential solution resolves this matter.

v/r
Phil
0
 
erobles1963Author Commented:
Excellent!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now