Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1910
  • Last Modified:

Domain user cannot save to C Drive

Windows 2003 domain, Windows 7 Pro

We have a user who needs to be able to save to the C Drive, to use their commercial banking application (some Java app).

I logged in as domain admin, added the domain user to the security permissions on the whole C Drive, for which it threw up errors for hyberfil.sys, pagefile.sys etc. No problems.

User stiill cannot save to C Drive. If they try they get a permissions error.

I added the domain user to the local admin group as a test, sure this would work.

Still doesnt.

What I noticed was that when I checked UAC before the user was part of the local admin group, UAC was ON. When I logged into the domain admin account, and also as the user with local admin rights, UAC showed as OFF.

Any ideas?
0
hongedit
Asked:
hongedit
  • 4
  • 2
  • 2
  • +1
1 Solution
 
McKnifeCommented:
Hi. You only need to do the following:
NTFS-Permissions - advanced - add user with write permissions and apply TO THIS FOLDER ONLY.
0
 
hongeditAuthor Commented:
Where am I looking for those options? Right-Click Properties?

They need root C access, not a subfolder within C
0
 
ded9Commented:
Article might help

This issue can occur if the Administrators group has been removed from the “Backup Files and Directories” user right.

    Click Start ORB, in the Search Field, type secpol.msc, and then press ENTER.
    Double-click Local Policies.
    Double-click User Rights Assignment.
    Double-click Back up Files and directories.
    Click Add, and then double-click the Local Administrators group
    Click OK.



Ref
http://answers.microsoft.com/en-us/windows/forum/windows_7-security/windows-7-cannot-save-files-to-c-even-after-making/938f2b50-b063-475b-8c5e-905d136df2e3



Ded9
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
Sushant GulatiConsultantCommented:
You cannot add and give a normal user an access to the System Files on the C: drive because since Windows Vista launch these people are much more secured in terms of accessing and making the changes at the File Structure Level, if we will compare to the legacy operating systems. To propogate the permissions and to take the ownership of the files, the user should be a part of the Domain Admin Group.

I am not sure with which you are logged and trying to access and what is the group membership and delegated rights are given to this user account. What method I would suggest is...

Create one shared folder on the C: drive.
Give this user Full Shared permissions
Give this user Full NTFS permissions

Create a MAP drive and assign Drive Letter.

See if this works. However, about the UAC confusion that you have, just go through this log.

http://vistavitals.blogspot.com/2008/01/uac-local-admin-vs-domain-admin.html

Hope this helps and good luck..!!

~SG~
0
 
McKnifeCommented:
Hi again.
ded, maybe you can explain to me what the "Backup Files and Directories" privilege has to do with saving (=writing to, not reading from) to the root of c:
By the way, any administrator already may write to c: ->when elevated<-, so the priv. is definitely not needed.

@hongedit: I know you are talking about the root of c: ("c: itself") and not about subfolders. I meant c: itself. Rightclick c: and adjust the permissions on the advanced section and apply TO THIS FOLDER ONLY.

0
 
hongeditAuthor Commented:
I just treid ded's suggestion first and it worked so looked into it no further.

0
 
McKnifeCommented:
@hongedit
Please. This is a security matter. How could one possibly make such a change without even knowing what he is doing? The description of the privilege reads
--
Back up files and directories

This user right determines which users can bypass file and directory, registry, and other persistent object permissions for the purposes of backing up the system.

Specifically, this user right is similar to granting the following permissions to the user or group in question on all files and folders on the system***:

Traverse Folder/Execute File
List Folder/Read Data
Read Attributes
Read Extended Attributes
Read Permissions

Caution

Assigning this user right can be a security risk. Since there is no way to be sure that a user is backing up data, stealing data, or copying data to be distributed, only assign this user right to trusted users.

Default on workstations and servers: Administrators
Backup Operators.

Default on domain controllers:Administrators
Backup Operators
Server Operators
--

*** OK, so where does it say "write data"? Nowhere.

This privilege does not work in terms of getting you any further. I am not sure what you have done, but if I grant my user this priv., I still can't write to the root of c:

So my advice is to remove that priv. again and go my way. For system security this is highly recommended.
0
 
McKnifeCommented:
Wait, I missed a thing. See my solution at http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_25059444.html#26403263
You also have to fire the command icacls c:\ /setintegritylevel M
(from an elevated command prompt).
0
 
Sushant GulatiConsultantCommented:
I agree with McKnife.. That's totally a breach of a security....
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now