Solved

RTMP request not responding over MAC from weborb

Posted on 2011-09-21
8
660 Views
Last Modified: 2013-11-17
Hello,

We have setup webORB for .net version 4.3.0.2 on IIS 7 windows server 2008.
Weborb is installed as a virtual directory.

Everything works perfectly except I try to make a request from MAC browser.
Earlier we thought there is some url related issue but now we found that after calling rtmp request the response is not being received on MAC and it keeps on waiting for ever.

The detailed scenario is as follow.

We load the page from IIS hosted site.
in that swf is first loaded.
The site is first making request to "http://[some domain]/[virtual directory]/weborb.aspx?diag"
this is for confirming that webORB messaging server is running or not.
If this request is loaded (which gets loaded on both MAC and windows)
then we make a rtmp request to webORB at port 2047 (we have changed it in Global.asax).

Now here if I am accessing the site from windows machine the response is received in timely manner whether rtmp connection call is succeeded or failed.
But if I am accessing the same page from any MAC browser the the response keeps on waiting.
Means I am not sure if the rtmp request is not being made from swf
or response from weborb is not recieved. :(

Main thing here to note is
If I test the same thing in my local network (in LAN ) the things is working over MAC as well.
But from Live rtmp request is not made as I said above.

And even more important thing to note here is
in local network the site is being accessed using "http" and on Live it is "https"

so any of the following may be the issue
- on MAC swf is not making rtmp request to weborb over Https
otherwise
- on MAC weborb is not responding for rtmp request over Https

So please guide or let me have some hint to resolve this or at least to test in proper manner.
0
Comment
Question by:BhavinKrish
  • 4
  • 2
8 Comments
 

Author Comment

by:BhavinKrish
ID: 36579951
is there any one getting the question or should I be more brief?
0
 
LVL 78

Expert Comment

by:David Johnson, CD, MVP
ID: 36588908
on MAC do you mean by using the apple macintosh safari browser? and does safari have the flash extension loaded from adobe flash?
0
 

Author Comment

by:BhavinKrish
ID: 36591158
yes Flash 10.3 plugin is installed on MAC (our application can not run on lower than 10.3 version so).
On every browser it is 10.3 and the issues stated above is coming on each browser in MAC.
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 78

Expert Comment

by:David Johnson, CD, MVP
ID: 36593910
and that is with the safari browser?  firewall issues on the mac?
0
 

Accepted Solution

by:
BhavinKrish earned 0 total points
ID: 36707739
no we have tried with all different kinds of network access.
Using USB donggles and lease lines as well.
0
 

Author Closing Comment

by:BhavinKrish
ID: 36895929
I did not get the solution and has to close this question because I am not able to ask any more question due to this.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now