Dynamics CRM E-mail Router not processing messsages (error #6511)

Microsoft Dynamics CRM E-mail router has problems with processing e-messages. This error started to appear a week after we've changed IP range of our company network. Everything works fine, except the CRM e-mail router cannot process incoming e-mail messages.

I've already tried installing updates to the CRM and several other suggestions from the tech forums. I've also checked this thread, but the solution did now work for me:
http://www.experts-exchange.com/Microsoft/Applications/Microsoft_Dynamics/Q_26663131.html

It seems to me, that it is the exact problem as described here, but no solutions:
http://techstack.com/forum/microsoft-crm/103941-odd-error-exchange-server-router-installed.html

Incoming e-mail messages have no special characters or attachments.

Here are the error details from the Application log(sorry for the cs_CZ locale):

Typ události:      Chyba
Zdroj události:      MSCRMEmail
Kategorie události:      Není k dispozici
ID události:      0
Datum:            21.9.2011
Cas:            14:57:35
Uživatel:            Není k dispozici
Pocítac:      CRM
Popis:
#6511 - An error occurred while checking the e-mail message with subject "Order request" in mailbox web-info@company.com for delivery to http://crm:5555/CompanyName. System.Web.Services.Protocols.SoapException: Server was unable to process request.
   v System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   v System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   v Microsoft.Crm.Sdk.Proxy.CrmService.Execute(Request Request)
   v Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.AcceptMessageInternal(EmailMessage emailMessage)
   v Microsoft.Crm.Tools.Email.Providers.Pop3PollingMailboxProvider.AcceptMessageInternal(EmailMessage emailMessage)
   v Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.AcceptMessage(EmailMessage emailMessage)
   v Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()\r\n
  0x80040b08
  The sender does not have an email address on the party record
  Platform
frrfrrAsked:
Who is Participating?
 
frrfrrAuthor Commented:
oh yes, here's the solution to my problem!
http://www.sadev.co.za/content/workflow-doesnt-work-imports-never-happen-emails-dont-flow-and-outlook-clients-cannot-connec

The main idea is that there is a bug in the Deployment Configuration Tool that causes some configuration settings in database to get blank (the URL of your CRM installation). You need to run these queries to fix that (replace <server> and <port> values to your settings)

USE MSCRM_CONFIG
Update DeploymentProperties SET NVarCharColumn = '<server>:<port>' WHERE ColumnName= 'AsyncSdkRootDomain'
Update DeploymentProperties SET NvarCharColumn = '<server>:<port>' WHERE ColumnName = 'ADSdkRootDomain'
Update DeploymentProperties SET NvarCharColumn = '<server>:<port>' WHERE ColumnName = 'ADWebApplicationRootDomain'
0
 
Feridun KadirPrincipal ConsultantCommented:
Did you investigate this part of the error message:

The sender does not have an email address on the party record
0
 
frrfrrAuthor Commented:
Yes, I've created a new mailbox for that user in Exchange. But it seems that it did not help.
0
 
frrfrrAuthor Commented:
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.