Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco 877 Config

Posted on 2011-09-21
12
Medium Priority
?
921 Views
Last Modified: 2012-05-12
Having trouble configuring a Cisco 877 for a bigpond ADSL2. I am getting Carrier Detect and the ATM0 interface seems to be connecting but cannot ping any addresses or load web pages. Running Config is:

ip dhcp pool LAN_CLIENTS
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
dns-server 61.9.194.49 61.9.195.193

interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
pvc 8/35
tx-ring-limit 3
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto

interface Vlan1
ip address 10.1.1.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip nat inside
ip route-cache flow

interface Dialer0
ip address negotiated
ip verify unicast reverse-path
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
encapsulation ppp
ip route-cache flow
dialer pool 1
ppp authentication chap callin
ppp chap hostname myusername@bigpond.com
ppp chap password mypassword

ip nat inside source list 190 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
access-list 190 permit ip 10.1.1.0 0.0.0.255 any

Thanks!
0
Comment
Question by:nealerocks
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
12 Comments
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 400 total points
ID: 36574090
You'll need to enable NAT.

ip nat inside source list 190 interface dialer0
int vlan1
 ip nat inside
int dialer0
 ip nat outside
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36574654
I honestly do see anything wrong with what you have posted. Can you post the entire config?
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36574659
I meant I don't see anything wrong.
0
Plesk WordPress Toolkit

Plesk's WordPress Toolkit allows server administrators, resellers and customers to manage their WordPress instances, enabling a variety of development workflows for WordPress admins of all skill levels, from beginners to pros.

See why 2/3 of Plesk servers use it.

 
LVL 12

Author Comment

by:nealerocks
ID: 36577460
Thanks for the comments. As you can see from the config I have enabled NAT. I tried to use SDM first but I could not edit the interfaces after creating them and was having trouble with the dynamic ip address on the dialer interface.

Here is the running config:

CISCO877#sh run
Building configuration...

Current configuration : 1717 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CISCO877
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxx
enable password xxxxxxx
!
no aaa new-model
!
!
dot11 syslog
no ip routing
no ip cef
no ip dhcp use vrf connected
!
ip dhcp pool LAN_CLIENTS
   network 10.1.1.0 255.255.255.0
   dns-server 61.9.194.49 61.9.195.193
   default-router 10.1.1.1
!
!
!
!
!
username xxxxxx privilege 15 secret 5 xxxxxxxx
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip route-cache
 no atm ilmi-keepalive
 pvc 8/35
  tx-ring-limit 3
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 10.1.1.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname xxxxxxxx
 ppp chap password 0 xxxxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
no ip http secure-server
ip nat inside source list 190 interface Dialer0 overload
!
access-list 190 permit ip 10.1.1.0 0.0.0.255 any
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password cisco
 login
!
scheduler max-task-time 5000
end

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 36577537
Where are you pinging from?

Have you verified that you can ping from the router to a public address?
0
 
LVL 26

Accepted Solution

by:
Soulja earned 1600 total points
ID: 36577996
Ip routing
Ip cef

You have them disabled.
0
 
LVL 12

Author Comment

by:nealerocks
ID: 36578094
The router cannot currently ping any external addresses. It did before but I started again because it was not working properly.
I will have access to the router again this afternoon. I will try your changes Soulja. What is the syntax?
0
 
LVL 12

Author Comment

by:nealerocks
ID: 36579327
Ok now the router can ping external IP addresses but the clients cant ping the cisco. If I connect my laptop directly to the cisco it still says media disconnected. All the interfaces are up.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 36579647
Post output of "show int status" and "show ip int brief"
0
 
LVL 12

Author Comment

by:nealerocks
ID: 36579745
I reconfigured from scratch using an older template I had and all is working fine now. Think I must have missed some random line. The interfaces were all up and ok. Just couldn't ping from a client.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36580762
Compare your old template and the config above with Diffmerge or something similar.
0
 
LVL 12

Author Comment

by:nealerocks
ID: 36595034
Think I stuffed up the VLAN interface.
Thanks for the help guys!
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

661 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question