Solved

Vlan on Cisco

Posted on 2011-09-21
10
496 Views
Last Modified: 2012-05-12
I need to add vlan and trunk port to Cisco WS-C2950-24 switch

port 10 must be trunk with vlan 25 and 110
port 9 must be vlan 110
port 8 must be vlan 25

Pls. assist.
0
Comment
Question by:soffcec
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
10 Comments
 
LVL 8

Assisted Solution

by:akalbfell
akalbfell earned 500 total points
ID: 36576461
I assume you already have the vlans setup. Just enter these commands exactly

conf t
int fa0/9
switchport access vlan 110

int fa0/8
switchport access vlan 25

exit

interface port-channel
switchport mode trunk

exit

int fa 0/10
channel-group 1 mode on

exit

write mem (if all works and trunk comes up ok)


0
 
LVL 8

Expert Comment

by:akalbfell
ID: 36576473
Sorry, this line interface port-channel should be interface port-channel 1

0
 

Author Comment

by:soffcec
ID: 36576556
Not working, do I need reebot or did I something wrong. (see code)
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
2    VLAN0002                         active
4    VLAN0004                         active
5    VLAN0005                         active
6    VLAN0006                         active
10   Einkanet                         active    Fa0/1
25   VLAN0025                         active    Fa0/8
32   VLAN0032                         active    Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/7
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22
33   VLAN0033                         active    Fa0/23, Fa0/24
91   Internet                         active
110  VLAN0110                         active    Fa0/9
911  VLAN0911                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

Open in new window

0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Expert Comment

by:akalbfell
ID: 36576571
can you do a show run and print the config here?

0
 
LVL 8

Assisted Solution

by:akalbfell
akalbfell earned 500 total points
ID: 36576591
also paste the results from show int fa 0/10
0
 

Author Comment

by:soffcec
ID: 36576600
Here it is
show interfaces fa 0/10
FastEthernet0/10 is up, line protocol is up
  Hardware is Fast Ethernet, address is 000c.8574.768a (bia 000c.8574.768a)
  MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:07:53, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     7019 packets input, 502583 bytes, 0 no buffer
     Received 4652 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 488 multicast, 0 pause input
     0 input packets with dribble condition detected
     365 packets output, 27615 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Open in new window

0
 
LVL 8

Assisted Solution

by:akalbfell
akalbfell earned 500 total points
ID: 36576628
port fa 0/10 is still in a vlan. can you do a show run and paste that and then i can tell you exactly what to enter.

If you could do it for the switch this one connects to as well that would be helpful.
0
 

Author Comment

by:soffcec
ID: 36576665
Hope its all here...
Building configuration...

Current configuration : 3002 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Druslubox
!
logging buffered 32000 debugging
enable secret 5 $1$rED/$9AQj4QCkyyCf.pMGsg0gs0
enable password 7 07173954
!
ip subnet-zero
no ip source-route
no ip domain-lookup
!
spanning-tree extend system-id
!
!
interface Port-channel1
 no ip address
 flowcontrol send off
!
interface FastEthernet0/1
 description LAN
 switchport access vlan 10
 no ip address
!
interface FastEthernet0/2
 switchport access vlan 32
 no ip address
 no cdp enable
!
interface FastEthernet0/3
 switchport access vlan 32
 switchport mode trunk
 no ip address
!
interface FastEthernet0/4
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/5
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/6
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/7
 description VDSL Sjoa
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/8
 switchport access vlan 25
 no ip address
!
interface FastEthernet0/9
 switchport access vlan 110
 no ip address
!
interface FastEthernet0/10
 switchport access vlan 32
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/11
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/12
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/13
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/14
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/15
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/16
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/17
 switchport access vlan 32
 no ip address
 no cdp enable
!
interface FastEthernet0/18
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/19
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/19
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/20
 switchport access vlan 32
 no ip address
 no cdp enable
!
interface FastEthernet0/21
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/22
 switchport access vlan 32
 no ip address
!
interface FastEthernet0/23
 description Tenging vip WAN router
 switchport access vlan 33
 no ip address
 speed 100
 spanning-tree portfast
!
interface FastEthernet0/24
 description Tenging vip LS
 switchport access vlan 33
 no ip address
 duplex full
 speed 100
 no cdp enable
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description 10 net
 ip address 10.0.10.254 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.0.10.125
no ip http server
!
snmp-server engineID local 800000090300000C85747681
snmp-server community tscman RO 1
snmp-server community public RO
banner login ^C
Ekki Fikta Maggi
^C
banner motd ^C
Ekki Fikta Maggi ^C
!
line con 0
 password 7 094B5C03160B16021E02033F39
line vty 0 4
 password 7 150A13
 login
line vty 5 15
 password 7 150A13
 login
!
ntp clock-period 17179826
ntp server 157.157.255.254 prefer
end

Open in new window

0
 
LVL 8

Accepted Solution

by:
akalbfell earned 500 total points
ID: 36576751
conf t
int port-channel1
switchport
switchport mode trunk

exit

int fa0/10
no switchport access vlan 32
switchport
switchport mode trunk
channel-group 1 mode on


exit


write mem


For security reasons change your passwords since you didnt omit them from the config. Not that it's super important since this isn't an internet facing device or anything but still better safe than sorry. Also don't use "enable password 7" anymore. It has no security at all. For example, that password you used is xxx. Make sure you use enable secret instead.



0
 

Author Comment

by:soffcec
ID: 36576869
This is almost working now.  VLAN 25 is OK  Vlan 110 came in for about 10 sec. and the stopped working. Like it lost some route, but Vlan 110 is working from the internet , so it should be alright.
Thanks alto.
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question