Solved

Our exchange database keeps unmounting during early morning hours

Posted on 2011-09-21
16
595 Views
Last Modified: 2012-08-13
The drive that our exchange database occupied on our server was running out of space. So we put in a NAS, mapped an iSCSI drive, and used MS iSCSI initiator to connect to the NAS, moved exchange to that new iSCSI drive.

It was working great for the first few weeks however recently it seems that the exchange databse will become dismounted during the early morning hours. I only find this out when I see that my exchange email is syncing on my phone, after which I remote in, check mailbox store on ESM, and right click to mount the database.  I've already tried restarting the server and the NAS and I have checked that the NAS should have plenty of space to accommodate our exchange database.

Any ideas on how to fix this? Thanks.
0
Comment
Question by:cllocc
  • 8
  • 6
  • 2
16 Comments
 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36576299
what is the exact size of your exchange DB?
Any event logs relating to size? You may have plenty of free space, but you may need to  change a registry key to allow your DB to grow larger without dismounting
0
 

Author Comment

by:cllocc
ID: 36576336
Currently our exchange database is at 38.9 GB. Exactly which log files would I need to check and where would they be located?
0
 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36576338
here is the link to the limits and reg key
Let me know if that is not the problem and we can look deeper
http://www.petri.co.il/change_store_size_limits_ex2003_sp2.htm
0
 

Author Comment

by:cllocc
ID: 36576375
Seems like the link is down, i'll check and see if google has a cached version of it
0
 

Author Comment

by:cllocc
ID: 36576387
If I wanted to backup the registry of win 2k3 server, is it the same process as the desktop variants? i.e. open regedit click on file and export?

0
 
LVL 13

Accepted Solution

by:
5g6tdcv4 earned 500 total points
ID: 36576405
here is the reg key
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Server name\Private-Mailbox Store GUID

    Create a new DWORD entry called "Database Size Limit in Gb" and give it the appropriate value for maximum database size in GB.

For Exchange Server 2003 Standard Edition type a value between 1 and 75 (the default is 18 GB).

For Exchange Server 2003 Enterprise Edition type a value between 1 and 8000 (the default is 8000 GB). Click OK.

The regedit backup is the same
0
 

Author Comment

by:cllocc
ID: 36576419
How can I tell if I have the Standard edition or the Enterprise edition?
0
 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36576435
0
The problems with reply email signatures

Do you wish that you could place an email signature under a reply? Well, unfortunately, you can't. That great Exchange/Office 365 signature you've created will just appear at the bottom of an email chain. What a pain! Is there really no way to solve this? Well, there might be...

 

Author Comment

by:cllocc
ID: 36576514
Thanks, seems like the Database Size Limit in Gb entry was already present. It was set to 24, and i upped it to 75.  Will see if exchange dismounts again tonite and if it doesnt, hopefully i'll throw you a party tomorrow with 500 points
0
 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36576538
Sweet. I would reboot server as wellafter reg change
Or restart exchange services
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36576620
I wouldn't set the limit to 75Gb - it won't give you any play when your database grows to 75Gb - you will then have to panic!

Set it to about 70Gb - which gives you 5gb spare and time to beat your users up to archive / purge their mailboxes.

You don't need to restart the server for the setting to take effect.

Alan
0
 

Author Comment

by:cllocc
ID: 36576955
restarting exchange services sounds easier, which services do i need to restart?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36576968
Just restart the Exchange Information Store service.
0
 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36576971
information store
0
 

Author Comment

by:cllocc
ID: 36576980
I wouldn't set the limit to 75Gb - it won't give you any play when your database grows to 75Gb - you will then have to panic!

Set it to about 70Gb - which gives you 5gb spare and time to beat your users up to archive / purge their mailboxes.

good point about the 75 GB, I will reset it to 70 GB
0
 

Author Closing Comment

by:cllocc
ID: 36580197
It seemed like that was exactly what my problem was.  A 500 Point Party goes to the expert with a sys admin password as a name!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now