Exchange 2010 message routing

Hi,

Trying to set up exchange within sbs 2011. This is a lab server set up. The current info:
 
- the ISP set up is Home so port 25 is blocked

- tried a smarthost set up using 2525, 587,...and a few others

- authorized domain set to true

- current connector is set to 587 (everywhere I could find to change it)

- anonymous is set

- able to recieve email from within the network just nothing outside the network

- "recieve enmail from IP addresses" has a default setting of server range but when I tried setting it to 0.0.0.0 - 255.255.255.255 email stopped all together

- Unable to determine if 587 is actually open and listening when netsh run

Thanks for the help.  

sio2yAsked:
Who is Participating?
 
louisreevesConnect With a Mentor Commented:
Ok. So the bottom line is need to have a mail hosting service of some type. If you set the send and recieve to use goole then you may as well just use google. Also,. if you have another user send from your organization, and you are using google as a send connector- guues who the reply to address is? YOU~!~~ I have this lab set up and it does work if you are the only person in your org. ok so let me present 2 ideas:

1. If you really want this to work - buy a dynamic dns mail service for mail forwarding. it sends the mail on on a non port 25 port. then you use outbound smtp serives for the send conector for another 20 bucks. The total cost is $100 per year for my .com name, dynamic dns service, smtp send and recieve.

2. If you really dont want to send the money (you have no choice for the inbound because you need someone to send mail to you on port 2525), you can use good as the send connector. you have to do as you said with the send connector and add the user and password under "authentication". you also have to run

Get-SendConnector -Identity "SENDCONNECTORNAME" | fl
(verity the port still says 25) then

Set-SendConnector -Identity "SENDCONNECTORNAME" -port 2525

that will set your port for you and you can send mail. Here is where the nightmate begins. you have to go to the settings in gmail and add and alternate name and reply email address. THis works for the user that is in the sent connector credentials. The other users? well not so pretty. first of all, all users who plan to use the server have to allo you send ad permissions on their google account and then you have to have alternate reply to addresses on your acount for their reply name. the reply to result?  See below:


 send as google
the format of the  reply to is as follows myname@gmail.com on behalf or youruser@yourdomain.com

My recomendation- Spend the hunred bux and use dynamic DNS

L
0
 
louisreevesCommented:
here is a document for doing dynamic DNS if you are interested.  DynamicDNS4yourLab5.docx
0
 
sio2yAuthor Commented:
Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.