Proxy issues with Office 2007 in terminal services

I have users in our Citrix Environment that are not able to access the proper proxy server. We use explicit proxies and they were recently changed. We used to use proxy.domain.com and now we use inetgw.domain.com. We pushed the change through GPO and IE works great. What I am seeing is my users, when accessing an Internet resource from MS Office applications (i.e. Word and PowerPoint) (links sent via email work just fine) they are being prompted for credentials for proxy.domain.com instead of inetgw.domain.com like they are in IE. All traffic is now being blocked to proxy.domain.com therefore they can no longer access these resources. I have spent the last day trying to track this down in the registry to no avail. I have a hunch that Office has cached the proxy server address somewhere but I can't find it anywhere. Can anyone point me in the right direction?
LVL 5
rkeith2412Asked:
Who is Participating?
 
rkeith2412Author Commented:
I am now seeing the issue when a user opens Word, clicks on New and tries to click on Labels.  This action takes them out to Office online and uses the old proxy instead of the new.  This issue is not isolated to these documents.  There has to be some place in the registry or their profile that Office is caching this proxy info.
0
 
Tony JLead Technical ArchitectCommented:
Hmm - Office should pick up the settings from what is in IE and the fact that Outlook is working leads me to think that the URL's etc in the documents affected are the actual cause.

If you open up say a Word document, and look at the hyperlink properties, what does it include?

If you re-type one of the links, in the same document, I imagine it'll actually work. Could you try that?
0
 
rkeith2412Author Commented:
I have already tried recreating the hyperlink as well as creating a brand new one. The links did work just fine for me. Not sure if it is because of my profile or the fact that I am an admin.
0
 
Tony JLead Technical ArchitectCommented:
I would ask a user to try creating one to say www.google.com in a blank document.  

I think it'll be fine.

URLs can be funny things in docs.
0
 
rkeith2412Author Commented:
For whatever reason this issue worked itself out on its own.  There must have been some cached info from when we changed proxy servers.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.