Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 491
  • Last Modified:

SBS2011 + SQL Server - Increase memory for SQL

We're running an SBS2011 server at a customers that has SQL 2008R2 loaded on it to run a production database.  The server has 24gb of memory in it however we've noticed that Exchange is using most of it... about 18gb only leaving about 2.3gb of space for SQL.  Is there a way to increase the amount of memory SQL uses helping to increase the speed.

Users notice a speed increase when I stop the information store and start it up again, temporarily releasing the memory used.  It seems to be a function of SBS to utilize as much memory as the server uses for Exchange,  a much smaller client is using over 8gb of exchange on a system with 12gb total mem.

Any help would be appreciated.
0
Fluid_Imagery
Asked:
Fluid_Imagery
  • 2
1 Solution
 
DBAduck - Ben MillerPrincipal ConsultantCommented:
You can set the maximum server memory for SQL to the amount you want to max out at so SQL does not take all the RAM, and then set the minimum server memory to a number that gives SQL Server the amount of RAM min that you want.

Here is how it works.  The SQL Server will request RAM when it needs it and when it gets it, it will give it back if the OS asks it.  But when you have the minimum memory set, then SQL Server will give back the RAM down to the minimum amount.  So if SQL Server gets 6 GB and you have the min set at 5 GB, the OS requests memory back, SQL will give back until it has only 5 GB allocated and won't give any more back.

So you may have to have SQL Server ramp up to get above the minimum and then Exchange can get some more after that, but that is the only thing I can suggest.
0
 
Fluid_ImageryAuthor Commented:
Where are the settings to change the Minimum and Maximum memory that SQL will use?
0
 
DBAduck - Ben MillerPrincipal ConsultantCommented:
sp_configure 'show advanced', 1
reconfigure with override
sp_configure 'max server', number in MB
reconfigure with override
sp_configure 'min server', number in MB
reconfigure with override
sp_configure 'show advanced', 0
reconfigure
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now