ESXi 5.0 licensing - upgrade from 4.1

I have 2 ESXi servers.

1 Poweredge 2950 with 4x CPU and 16 gig of RAM.
1 Poweredge R710 with 4x CPU and 24 gig RAM

At the moment i am running the free 3.5 and 4.1 version.

The question is, will a upgrade to 5.0 free ESXi limit my resources on these servers? I have searched around for this question, but have just got more confused.
frankEQSAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Luciano PatrãoConnect With a Mentor ICT Senior Infraestructure  Engineer  Commented:
Hi

For running in that Server in ESXi versions you can.

Check here

http://partnerweb.vmware.com/comp_guide2/detail.php?deviceCategory=server&productid=3647&vcl=true

Search for 2950 and R710.

You should update the BIOS and firmware.

But regarding ESXi free versions you will have a 32Gb limit of memory for free versions. So I think fits on your servers.

Users can remotely manage individual vSphere Hypervisor hosts using the vSphere Client. vSphere Hypervisor is entitled to 32GB of vRAM per server (regardless of the number of processors) and can be utilized on servers with up to 32GB of physical RAM.

But I recomend that you test first that version on that servers, before put in production. Like installing the VMware in a USB key and test. Be aware of your Storage when you install a new VMware version, on the test install, do not erase your partitions.

Hope this can help.

Jail
0
 
davorinCommented:
I don't think so. Look at the end of this page:
http://www.vmware.com/products/vsphere/esxi-and-esx/compare.html

32-way virtual SMP, 1TB virtual machine RAM,
0
 
davorinCommented:
Another link - look at restrictions for host computer:
http://en.wikipedia.org/wiki/Comparison_of_platform_virtual_machines
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
VMware vSphere Hypervisor (ESXi 5.0)

VMware vSphere Hypervisor is a free product that provides a simple
and easy way to get started with virtualization at no cost. vSphere
Hypervisor provides only basic virtualization capabilities allowing
to virtualize servers and run applications in virtual machines in a
matter of minutes. vSphere Hypervisor cannot connect to VMware
vCenter Server and therefore cannot be centrally managed. Users
can remotely manage individual vSphere Hypervisor hosts using
the vSphere Client. vSphere Hypervisor is entitled to 32GB of vRAM
per server (regardless of the number of processors) and can be
utilized on servers with up to 32GB of physical RAM.


Source
http://www.vmware.com/files/pdf/vsphere_pricing.pdf

It has been confusing because at first VMware stated the FREE version of ESXi 5.0 would be allocated only 8GB of vRAM per CPU.

This has now been finally changed, and you will be allowed to use a maximum of 32GB vRAM.

So, in answer to your question, YES, there are restrictions in VMware vSphere 5.0 (ESXi 5.0) compared to ESXi 3.5 and ESXi 4.1, because there was no memory restriction.

It depends if, on your servers, you are likely to increase the memory in the future, because at present you are undert those limits.

0
 
coolsport00Connect With a Mentor Commented:
Yes & no; I pretty much believe the RAM limitation has been explained, but regarding CPU/cores, there is no limit. So yes, you have a memory limit, but no, there (now) is no CPU/cores limit. Take note of @hanccocka's copy/paste from the PDF link he provided -> "...REGARDLESS OF THE NUMBER OF PROCESSORS...". Basically, remember this, regardless what edition you go with, if you decide to purchase a licensed edition in the future, there are no CPU restrictions, just soley memory (vRAM pool) restrictions. You would still have to license for however many physical CPU SOCKETS you have, but there are no limits on # of sockets, or # of cores you can have.

Now, since you are way under limits for memory, there will be no concerns. If you're not experiencing any issues, I wouldn't upgrade. Actually, if anything, I would only upgrade your 3.x host to 4.1.

Hope that helps.

~coolsport00
0
 
frankEQSAuthor Commented:
Thanks for good response :).

BestWay gets the most points since he was fastest and gave a good answer to my Q.

Spreading the rest points between the others for good clarification and good points :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.