An error copying some or all of the selected files using Webbdav and IIS7

Hi Guys,
I have configured a Webdav server on Windows 2008 R2 using IIS7 but when I try to upload large files for example as a test I am uplaoding file which is 900MB in size it comes back to me saying "An error copying some or all of the selected files"

I tried playing with the config file but wanted to be sure on what the fix actually is, the requirement is to have files upto 6GB to be uploaded and downloaded.

Thanks in advance guys.
kerry_dsouzaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vinsvinCommented:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
Right click on the FileSizeLimitInBytes and click Modify
Click on Decimal
In the Value data box, type 4294967295, and then click OK. Note this sets the maximum you can download from the Webdav to 4 gig at one time, I haven’t figured out how to make it unlimited so if you want to download more you need to split it up.
kerry_dsouzaAuthor Commented:
Hi Vinsin!

Is this seeting on the server or the windows XP machine coz on the server I dont have a "WebClient" Sub-key but on my XP machine I do so i created that anyways to the value u just mentioned but you have also said that  this is for the download but I am not able to upload file over 300 Mb (I tried uploading a .pst file for testing)

Since I am using IIS 7 I went to the "Default Website" in ISS console and double clicked on "Request filtering --> edit feature settings and Maximum allowed content length I changed it to 4294967295"

I also did the same for my Webshare virtual directory where the user connect its under the Default Website Site and I went and modified the same value under the Request Filtering Icon"

After which I did a IISRESET
I am currently uploading a 350 MB pst fie lets see if I succeeed this time....
kerry_dsouzaAuthor Commented:
This is what I have done under the DWS, let see if it works....

 Setting under the default website

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kerry_dsouzaAuthor Commented:
The Requets Filtering modification worked
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
File Sharing Software

From novice to tech pro — start learning today.