Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Outlook 2007 Exchange Proxy settings are not retained

Posted on 2011-09-22
18
Medium Priority
?
1,450 Views
Last Modified: 2012-05-12
We have a client, newly put onto hosted Exchange (2010). We have a problem with the Outlook proxy settings, for some of the users the correct settings are not retained.  
I have created new profiles, even re-installed MS Office, but the setting are not kep by Outlook, when the user re-startes Outlook they are incorrect.

In the "only connect to proxy servers..." the box is ticked (checked) and it shouldn't be, and a setting a "msstd:.." text appears in the box below. This is wrong this should be blank. See attached images of the right one and wrong one.

I have seen in E-E and elsewhwhere of this problem, but no satisfactory solution.

If you manually change it back and re-start Outlook it will be OK, but on next openong of Outlook, they will have reverted to the wrong settings and Outlook won't connect to the Exchange server.

It seems like a bug in Outlook?

Any ideas?




Capture-2-wrong-settings.JPG
Capture.JPG
0
Comment
Question by:gerlis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 8
18 Comments
 
LVL 49

Expert Comment

by:Akhater
ID: 36579279
This setting is taken from Autodicsover not a bug from outlook at all.

There is no need to remove it for outlook anywhere to work if you are having problems refer to your hosting company
0
 
LVL 1

Author Comment

by:gerlis
ID: 36580418
Thanks, Akhater

So do you mean that the autodiscover feature is causing this to happen? Bear in mind they are using Outlook 2007 (not 2010) which does not have this feature, although Exchange 2010 does allow it.

When the "msstd:..." text appears in the "only connect to..." field, their Outlook does not connect. It has to be manually removed and Outlook re-started to connect.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36580430
outlook 2007 has autodiscover just like 2010 and yes it is caused by the autodiscover feature
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 1

Author Comment

by:gerlis
ID: 36586177
Yes you are right (as if I ever doubted you!) I am liasing with the hosting provider, they, too have tried it at their end with Outlook2007 and autodiscover and it didn't work for them! They had to set it up manually

I have now installed Outlook 2010 on thier system and attempted to set it up for a Hosted Exchange account

The autodiscover did not work; is reaches the point where it is trying to connect to obtain the server information and just hangs.

Using the manual method Outlook was very unstable but eventually did manage to set it up, but we still have the same problem as before (with Outlook 2007), of the msstd: appearing in the proxy settings and it won't connect, take it out and it does connect, on re-start Outlook 2010 msstd: re-appears and no connection!

Could it be a a problem with the hosting servers, certificates, or whatever?

0
 
LVL 49

Expert Comment

by:Akhater
ID: 36588350
Yes it is looks like a prob with the certificate, what outlook is doing it is refusing to connect with a certificate with CN other than exchange2010.livemail.co.uk
0
 
LVL 1

Author Comment

by:gerlis
ID: 36588727
Thanks, however the hosting company have suggested it might be also to do with the autodiscover feature, but that the settings on the domain are defaulting to use it, I quote: "Outlook does periodically use autodiscover to ensure that it has the most up to date settings for connecting to the account. Unfortunately this can result in Outlook changing any settings that have been manually set...."

So, firstly I will remove the autodiscover CNAME record from their DNS and see if that sorts it out. If not then I will propose to them they have a certificate issue as you've suggested.

0
 
LVL 49

Expert Comment

by:Akhater
ID: 36589942
It is autodiscover feature this is what I told you from the start :)


and yes autodiscover will periodically override all manual settings so you will need to either disable autodiscover or let them fix their certificate
0
 
LVL 1

Author Comment

by:gerlis
ID: 36598190
Removing the autodiscover from the CNAME record made no difference unfortunately :-(

Hosting company have suggested:

___
When we set it up we used the following settings (some of these differ to the guide we supply):

Server: cas.email.local
Untick 'Use Cached Exchange Mode'

In the Exchange Proxy Settings:

Leave the option 'Only connect to proxy servers that have this principal name in their certificate' unticked
Leave the option 'On fast networks, connect using HTTP first, then connect using TCP/IP' unticked
Leave the option 'On slow networks, connect using HTTP first, then connect using TCP/IP' unticked
Set the option 'Use this authentication when connecting to my proxy server for Exchange' to 'Basic Authentication'
___

This made little difference, after initially persuading Outlook to accept these settings instead, it would open and work once, then subsequent times Outlook would try faile to open with an error dialogue "Microsoft Exchange is unavailable." with three options to click: Retry, Work Offline, Cancel. None have any effect.

I've tried this with different PCs at this client on Outlook 2007 and Outlook 2010. All ar eon Win XP (albeit on PCs only about 18 months old.) I will try it on a win 7 PC today.
0
 
LVL 1

Author Comment

by:gerlis
ID: 36599006
This is what I have just sent to my Hosting Provider (again Akhater, you may be right, it looks like a certificate thing?)

So could it be a certifcate problem which only affects Win XP?

___________________________________________


"I think I may have narrowed down the cause of the problem?

The PCs not connecting (when using the Manual settings exactly as described in: https://resellers.fasthosts.co.uk/app/answers/detail/a_id/1657 )

are all running Windows XP SP3. The client's Windows 7 machines and one Vista machine, and ours here (running Win 7) with Outlook 2007 connect & work OK.

I found these two Microsoft technet articles which refer to this problem that: "XP is not willing to look at next lines on a SAN certificate, but Windows vista/7 does. "

http://social.technet.microsoft.com/Forums/en/exchange2010/thread/a7c25d6a-7cfc-40a1-a17e-a1f05f637d53

http://social.technet.microsoft.com/Forums/en-AU/exchangesvrclients/thread/2bd0471f-751c-4f66-bf19-9abfd00d3cba

I have been advised a few days ago on another forum that this problem might be related to the certifcate."

0
 
LVL 1

Author Comment

by:gerlis
ID: 36600271
I've even foud this (Microsoft Technet article) of the problem with certificates in Exchange 2010 and Windows XP

See

http://technet.microsoft.com/en-us/library/dd351044.aspx

Scroll down to the end.

"Client Limitations
Outlook on Windows XP or earlier operating systems " 
0
 
LVL 49

Accepted Solution

by:
Akhater earned 2000 total points
ID: 36708176
Yes I know it would work on windows 7 or later and in my post on 36588350 I told you it the CN should be the same.

However I am still insisting on the certificate issue because, in your case, they have only  exchange2010.livemail.co.uk in the certificate so the CN of the certificate is the same but you are still facing the issue,
0
 
LVL 1

Author Comment

by:gerlis
ID: 36708187
"CN"? (sorry if I am being dim!)
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36708198
CN = Common Name
0
 
LVL 1

Author Comment

by:gerlis
ID: 36708254
Thanks!

I am still waiting to hear from the hosting company, will chase them up today.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36708262
give testexchangeconnectivity.com a test see if it returns any error
0
 
LVL 1

Author Comment

by:gerlis
ID: 36893404
The problem seems to have been fixed, all the XP machines are now connecting OK. The ISP, however has not responded, I have been chasing them up and spoke to them today, they are goging to liase with the engineer. Not very good service or communication!

Almost certainly a certifcate problem as I found in the MS technet articles, and first allued here by akhater, whcih they seem to have fixed.

I think a stroppy communcation on my part to their MD is next.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36894555
glad it worked out, you can bet it was the certificate

thanks for the update
0
 
LVL 1

Author Comment

by:gerlis
ID: 36909881
Eventually the ISP said (after I had given them the links to the MS articles and then told them it was working):

"I have had a response from our engineers, who advised that nothing had been changed for your Exchange mailboxes to work on XP, so it looks like maybe something was updated with the computer to allow this functionality."

Oh yea?  6 XP computers and all suddenly had some update? I think not. Too co-incidental it started working just after I told them about the known certificate problem with XP (backed up with your conclusion).

I'll go with you Akhater.   Thanks for your help. Points are yours.

0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
This video discusses moving either the default database or any database to a new volume.
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question