Solved

How do I add the default vlan to trunk port on my Cisco Catalyst

Posted on 2011-09-22
12
298 Views
Last Modified: 2012-05-12
I have one trunk port on my switch and need to let the default lan access thru it.  
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
2    VLAN0002                         active
4    VLAN0004                         active
5    VLAN0005                         active
6    VLAN0006                         active
10   Einkanet                         active    Fa0/1
22   VLAN0022                         active    Fa0/7
25   VLAN0025                         active    Fa0/8
32   VLAN0032                         active    Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22
33   VLAN0033                         active    Fa0/23, Fa0/24
91   Internet                         active
110  VLAN0110                         active    Fa0/9
911  VLAN0911                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
4    enet  100004     1500  -      -      -        -    -        0      0
5    enet  100005     1500  -      -      -        -    -        0      0
6    enet  100006     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
22   enet  100022     1500  -      -      -        -    -        0      0
25   enet  100025     1500  -      -      -        -    -        0      0
32   enet  100032     1500  -      -      -        -    -        0      0
33   enet  100033     1500  -      -      -        -    -        0      0
91   enet  100091     1500  -      -      -        -    -        0      0
110  enet  100110     1500  -      -      -        -    -        0      0
911  enet  100911     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Open in new window

0
Comment
Question by:soffcec
  • 5
  • 3
  • 2
  • +2
12 Comments
 

Author Comment

by:soffcec
ID: 36579361
or how do I add vlan to my trunk port
0
 
LVL 18

Assisted Solution

by:fgasimzade
fgasimzade earned 215 total points
ID: 36579773
Since vlan 1 is your native vlan, it is added to the trunk port by default. Just to make sure can you post your trunk port config?
0
 

Author Comment

by:soffcec
ID: 36579840
How do i do that ?   show interface trunk shows nothing.
0
 
LVL 18

Assisted Solution

by:fgasimzade
fgasimzade earned 215 total points
ID: 36579871
Try

sh run interface fa0/x where x is the number of your trunk port
0
 

Author Comment

by:soffcec
ID: 36579878
sh run interface fa0/10
Building configuration...

Current configuration : 97 bytes
!
interface FastEthernet0/10
 switchport mode trunk
 no ip address
 channel-group 1 mode on
end
0
 
LVL 45

Assisted Solution

by:Craig Beck
Craig Beck earned 143 total points
ID: 36579882
If you have restricted the VLANs which can traverse the trunk using the switchport trunk allowed vlan command you will need to allow VLAN1 using the switchport trunk allow vlan add 1 command.

fgasimzade is asking you to post the interface configuration for the port which is your trunk...

show run int fa0/10

...for example.
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:soffcec
ID: 36579912
sh run interface fa0/10
Building configuration...

Current configuration : 97 bytes
!
interface FastEthernet0/10
 switchport mode trunk
 no ip address
 channel-group 1 mode on
end
0
 
LVL 18

Assisted Solution

by:fgasimzade
fgasimzade earned 215 total points
ID: 36579936
Thanks, craiqbeck, this is why I asked to post switchports config.

Soffcec, there is no restricted vlans on your trunk port, so vlan 1 is permitted untagged by default
0
 
LVL 45

Assisted Solution

by:Craig Beck
Craig Beck earned 143 total points
ID: 36579969
No problem :-) @fgasimzade - you are correct!

You don't need the channel-group 1 mode on command on the interface as it is not part of an EtherChannel, but it shouldn't cause a problem if you leave it there.
0
 
LVL 3

Assisted Solution

by:jrgcomputing
jrgcomputing earned 71 total points
ID: 36579990
Its also worth setting the trunk encapsulation to dot1q. To set this do the following: -

switch#conf t
switch(config)#interface FastEthernet0/10
switch(config-if)#switchport trunk encapsulation dot1q
switch(config-if)#exit
switch(config)#exit
switch#wr

You will also need to do this on the receiving switch

If you just want to extend the default vlan to another switch set the port up as: -

switch#conf t
switch(config)#interface FastEthernet0/10
switch(config-if)#switchport mode access
switch(config-if)#exit
switch(config)#exit
switch#wr
0
 
LVL 2

Accepted Solution

by:
Paktusjet earned 71 total points
ID: 36580950
Ports can only be one of 2 kinds, a Access port or a Trunk port. When u make a port a trunk link then it will pass all vlans unless you specify only certain vlans across. Since you have your port in a portchannel are you even sure that port is up?

Do a show ip int brief and see if that port and the port channel is up up. If not take it out of the portchannel unless your wanting to etherchannel.
0
 

Author Comment

by:soffcec
ID: 36595673
My other switch is RubyTec and it is a long way from me. I could not connect to it because it was on the default vlan. I got my broken RubyTec fixed so everything is working now.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Is your computer hacked? learn how to detect and delete malware in your PC
Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now