Solved

ubuntu bcm43224 driver

Posted on 2011-09-22
8
995 Views
Last Modified: 2012-05-12
i am looking for ubuntu 64bit driver for broadcom BCM43224 802.11
0
Comment
Question by:ammadeyy2020
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 21

Expert Comment

by:Papertrip
ID: 36579799
Check this link out.
0
 

Author Comment

by:ammadeyy2020
ID: 36579816
i tried that link,
sudo apt-get install bcmwl-kernel-source

it gives error
Errors were encountered while processing
bcmwl-kernel-source
0
 
LVL 62

Expert Comment

by:gheist
ID: 36583186
14e4:4322
      supported? no
      BCM4322

please post lspci for us to verify if it is supported by any driver around.
given current bits of information it is NOT supported by b43 or bcm43xx drivers even if you manage to use wired network to get b43/b43legacy firmware
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 62

Expert Comment

by:gheist
ID: 36583218
you can easily check if it works

you need a package called b43-fwcutter, then get a recent firmware from page mentioned in it's manual, and if it works at all it may just start working.

do not hold me responsible if bcmwl installation did irreversible damage like deleting b43 module etc.
also use latest version of ubuntu, older may have older wireless core which has no idea it is compatible with your PCI adapter
0
 

Author Comment

by:ammadeyy2020
ID: 36592174
root@bt:~# lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation 5 Series/3400 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 335M] (rev a2)
02:00.0 Ethernet controller: Atheros Communications AR8132 Fast Ethernet (rev c0)
03:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)
04:00.0 FireWire (IEEE 1394): JMicron Technology Corp. IEEE 1394 Host Controller (rev 30)
04:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev30)
04:00.3 System peripheral: JMicron Technology Corp. MS Host Controller (rev 30)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)ff:00.1 Host bridge: Intel Corpora

0
 

Author Comment

by:ammadeyy2020
ID: 36592175
i am using backtrack 5 R1
0
 
LVL 62

Accepted Solution

by:
gheist earned 500 total points
ID: 36593057
backtrack is not ubuntu.
it has old drivers that do not support b43 card present on your system.
using broadcom-wl drivers does not suit purpose of backtrack.

your card requires Linux kernel v3.1 or better.
0
 
LVL 62

Expert Comment

by:gheist
ID: 36963500
Driver is present on OpenSUSE 12.1 ( a developer version on their site)
Just give it a try. In liveUSB config you can install some of less sophisticated components of BT5, might be enough to try out.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

No security measures warrant 100% as a "silver bullet". The truth is we also cannot assume anything but a defensive and vigilance posture. Adopt no trust by default and reveal in assumption. Only assume anonymity or invisibility in the reverse. Safeā€¦
Fine Tune your automatic Updates for Ubuntu / Debian
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question