Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

IIS 6 Create a Website based on IP and Port - Error Internet Explorer cannot display the webpage

Posted on 2011-09-22
5
Medium Priority
?
563 Views
Last Modified: 2012-08-14
Hi All,

I have configured a website in IIS 6 so that I just only need to reference the IP address and port as per my previous question at

http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Q_27307076.html 

I ran the command netstat to make sure to choose a port that isn't currently being used - port 88 in my case.

When I go to the IP address and port like so - http://172.0.0.1:88 I just get the error 'Internet Explorer cannot display the webpage'  - ignore the IP here as it is for example purposes and understand its and internal one.

Can anyone suggest what I could be doing wrong?

Thanks,

Rit
0
Comment
Question by:rito1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 10

Expert Comment

by:gaurav05
ID: 36580088
Hi,

I attached the screen shot.

you need to assign ip address and port no in that red box.


let us know.
ScreenShot001.bmp
0
 
LVL 1

Author Comment

by:rito1
ID: 36581196
My appologies, its IIS 7. (doh!)

The IP address and port 88 are showing in these fields correctly. though they are located in a different place - Site Bindings section rather than Properties - Web site :-) Still get the error.
0
 
LVL 10

Accepted Solution

by:
gaurav05 earned 2000 total points
ID: 36585144
Hi,

check whether the site is started, and what end-points its
configured to run on, by running the following from command line:

> %windir%\system32\inetsrv\AppCmd.exe list sites

At this point, you may get a configuration error indicating malformed configuration in the sites section –
 in that case, you need to fix this to proceed.  Once the error has been fixed, the resulting output should include your site as follows:

SITE "Default Web Site" (id:1,bindings:http/*:80:,state:Started)

If you site is not listed, well, then you know the problem.
If the site definition does not contain the proper binding
(in the form of protocol/[ip-address-list-or-*]:port:[host-header-list-or-blank]),
then you need to add the missing binding.


Start the event viewer (Start>Run>eventvwr.exe), and look for an error in the “System”
event log under “Windows Logs”, with “WAS” as the event source.  You may see something
like this:

Event 5161:
Site 1 has no root application defined, so the site will be ignored.

This should most of the time hold the key to what you need to do to make sure the site is valid.  
The following may cause your site to not be valid:
The site does not contain a root application (with path = “/”)
The site does not contain a single valid binding
A binding is invalid or conflicts with another binding on the machine
Once you’ve made the required configuration changes, you can start the site like this:

> %windir%\system32\inetsrv\AppCmd.exe start site "Default Web Site"

Where "Default Web Site" is replaced with the name of your site.


if everything above is  ok then

Try switching the AppPool to Classic .NET mode rather than integrated mode.

You can do this on the Application Pool's Basic Settings in IIS Manager
0
 
LVL 1

Author Comment

by:rito1
ID: 36585411
Hi gaurav05,

it turns out that all ports are being blocked by the firewall other than the ones being used.

Thanks for you expertise.

Rit
0
 
LVL 1

Author Closing Comment

by:rito1
ID: 36585412
Excellent info.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
When it comes to security, close monitoring is a must. According to WhiteHat Security annual report, a substantial number of all web applications are vulnerable always. Monitis offers a new product - fully-featured Website security monitoring and pr…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question