Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Wireless on XP clients, PEAP setting not applying from Group Policy GPO

Posted on 2011-09-22
7
Medium Priority
?
1,010 Views
Last Modified: 2013-12-09
Hi

I have a problem as follows.

I have set up some Cisco Aironet 1042 APs. These use RADIUS to authenticate the clients against our Active Directory using EAP.

Our Windows 7 laptops will connect and authenticate straight away with no problem.

By default when the Windows XP SP3 clients try to connect they display an error "Windows was unable to find a certificate to log you on to the network xxxxx". This can be resolved by setting the EAP type to 'PEAP' instead of 'Use smart card or other certificate'.

I have created a GPO for the XP clients to pre-configure the SSID so that the correct settings should be available, however the 'EAP Type Protected PEAP (PEAP)' setting does not get set on the client. All the other GPO settings do get set correctly.

Does anyone know why this setting is not being applied by the GPO?

Thanks in advance.
0
Comment
Question by:MartynLawson
  • 4
  • 3
7 Comments
 
LVL 11

Expert Comment

by:TheGeezer2010
ID: 36580133
What is the GPO setting you are using - Windows 2008 server ?
0
 
LVL 1

Author Comment

by:MartynLawson
ID: 36580679
Hi
It's Windows 2003 (not R2)

Thanks
0
 
LVL 11

Expert Comment

by:TheGeezer2010
ID: 36581249
And which GP setting are you using ?
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
LVL 1

Author Comment

by:MartynLawson
ID: 36581355
In the Computer Configuration/Windows Settings/Security Settings/Wireless Network, I have created a GPO called 'Wifi'. In the Preferred Networks section I've added my SSID, and in the IEEE 802.1x section I've set the EAP type to 'Protected EAP (PEAP)'

Thanks
0
 
LVL 1

Accepted Solution

by:
MartynLawson earned 0 total points
ID: 36708969
I have resolved this issue. You need to extend the Active Directory schema to allow 802.11 PEAP authentication, Windows 2003 domain controllers do not support this by out of the box. See the following TechNet page which explains how to do it. It takes approximately minutes.

http://technet.microsoft.com/en-us/library/bb727029.aspx
0
 
LVL 1

Author Closing Comment

by:MartynLawson
ID: 36898842
Correct solution.
0
 
LVL 11

Expert Comment

by:TheGeezer2010
ID: 36709645
Nice one !!
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here's a look at newsworthy articles and community happenings during the last month.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question