Solved

IE add-ons still appear even though files have been removed

Posted on 2011-09-22
7
1,952 Views
Last Modified: 2012-05-12
The situation: I am a consultant and I manage several Kaseya and Trend servers. I recently upgraded two of the Kaseya servers. This resulted in the browser plug-ins for Live Connect being out of sync. So part of LC works and part of it doesn't. Of course I contacted Kaseya support about this. They suggested uninstalling the plugins (BHOs) and reinstalling. This didn't work.

In older versions of IE, you could actually go into IE, Manage Add-Ons, and uninstall add-ons from there. IE 9 doesn't let you do this. All you can do is disable the BHO. When I went to C:\Windows\Downloaded Program Files, most of the BHOs showed up as "Damaged". I think I know why. Kaseya support had me run a script that basically foobed up all the files in that folder. The non-Kaseya BHOs were fine prior.

I installed HiJackThis and used it to wack all the BHOs on my workstation assuming that I would be able to reinstall any that I needed. They claimed to be damaged and weren't working anyhow. The place where they were claiming to be damaged was shown when you open Windows Explorer to C:\Windows\Downloaded Program Files. After wacking the BHOs with HiJackThis, I then went to C:\Windows\Downloaded Program Files via command prompt and wacked everything in that folder including the conflict subfolders. You can't actually get at the files through Windows Explorer as it's seen as one of the special system folders. This should have resulted in a full wacking of components of the plug-ins.

I then proceeded to go to a website for an Axis camera. That plug-in reinstalled no problem and works great. I went to one Trend server website, the plug-in reinstalled no problem. Trend server #2, no luck. I noticed in HijackThis, each plugin for each Trend server was considered different. Literally, the entry in HiJackThis was one for each server.  I have a ticket in with Trend on how to force a reinstall of the browser plug-in. The one that didn't work STILL had one of the Trend plug-in components showing up in IE Manage Add-Ons as "Enabled".

For each plug-in in question, I am finding that most of the plug-in is gone, but not all of it. Which is why when I try to reinstall them, it's not working consistently. Let's take the Kaseya plug-ins as the prime example. Here is a screen of what the contents of C:\Windows\Downloaded Program Files looks like now. You will see that Kaseya plug-ins don't exist there. C:\Windows\Downloaded Program Files

And this is a screen of of the browser add-ins that claim to be installed. Kaseya plugins show up but aren't installedYou can see that Kaseya claims to be "enabled", but the components don't show up in Downloaded Program Files. The Kaseya plugin files also don't appear when you peruse that folder via the command prompt. I know what it is supposed to look like when the files are there because they were previously there in the Downloaded Program Files folder before I wacked them. They are not reappearing after a plug-in reinstall attempt. I can only assume this is because the browser thinks they are already installed.

So my thinking is that if I could figure out a way to convince IE that the Kaseya plug-ins were not installed and no longer "Enabled" in the Manage Add-Ons, then they would reinstall properly.

I included the Trend server plug-in description only as an example that this isn't really about Kaseya plug-ins, this is really about how to convince IE that an add-in isn't really installed anymore. And this would allow reinstallation clean.

The totality of the question is then, how do you manually clean out entries in the IE browser Manage Add-Ons area to convince IE that the plug-in isn't installed anymore?

P.S. No I haven't tried reinstalling the browser. I haven't had good luck with IE doing a clean uninstall in the past and a reinstall. Doing that has never actually resolved any issue with IE for me because IE is so deeply embedded with the OS. Any suggestions you have on my question are greatly appreciated.
0
Comment
Question by:Felicia King
  • 5
  • 2
7 Comments
 
LVL 66

Expert Comment

by:johnb6767
ID: 36584648
"In older versions of IE, you could actually go into IE, Manage Add-Ons, and uninstall add-ons from there. IE 9 doesn't let you do this."

You can still do this in IE9. When viewing the control, Right Click>More Information, and use the "Remove" button at the bottom.....

Easy way to remove the registry information...

Http://live.sysinternals.com/autoruns.exe

Use the Internet Explorer Tab.... Either that, or try UNREGISTERING the .DLL/.OCX file, listed in the Manage Addons details....
0
 
LVL 4

Author Comment

by:Felicia King
ID: 36586543
Thanks for the info, I didn't think about using autoruns before. For many of the controls, the remove button is grayed out. Others, the button is there, but clicking it does nothing. Autoruns is only displaying the items that are correctly installed and which have content in C:\Windows\Downloaded Program Files. I will try manually unregistering the DLL and OCX files next.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 36589456
"Others, the button is there, but clicking it does nothing"

Only thing I can say about this, is that it doesn't "live" refresh the window... You don't see the changes until you reopen the Addon Manager..... (which I am sure you have done numerous times....
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 4

Author Comment

by:Felicia King
ID: 36735174
I found I was able to uninstall the add-ons by a careful application of regsvr32 /u /s filename then delete the actual file. However, this doesn't actually allow the activex controls to reinstall. It's like there are some remnants still hanging out there in limbo in the registry. So I searched the registry and found some components hanging out. Removed those and attempted reinstall of the controls. No good. Still busted.
Trend did provide an answer to their software. The URL is here: http://esupport.trendmicro.com/solution/en-us/1053538.aspx

I have since found out that many folks are experiencing the same problem with Kaseya 6.2 live connect plugins that I am. This problem only appears to affect Windows 7 and Vista. Windows XP with IE 8 is unaffected.
0
 
LVL 4

Author Comment

by:Felicia King
ID: 36931599
An update on the situation: The problem appears to be a software bug in Kaseya's Live Connect product. Many people are currently experiencing the problem. Kaseya has not been able to fix the issue at this time. It appears to only affect Vista and Win7 and IE9. If Vista with IE8 is also affected. WinXP with IE8 works fine. Live Connect plugins also work in Firefox.
I wrote a script that was very effective at uninstalling the old plugins cleanly. The code is attached.
:: kasRmtHlp Class
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\kaxRemote.dll"
	del /q "C:\Windows\Downloaded Program Files\kaxRemote.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\CONFLICT.3\kaxRemote.dll"
	del /q "C:\Windows\Downloaded Program Files\\CONFLICT.3\kaxRemote.dll"

:: UsersGroup class
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\LocalUsersGroupsX.dll
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\LocalUsersGroupsX.dll
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\LocalUsersGroupsX61.dll"
	del /q 	"C:\Windows\Downloaded Program Files\LocalUsersGroupsX61.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\LocalUsersGroupsX.dll"
	del /q 	"C:\Windows\Downloaded Program Files\LocalUsersGroupsX.dll"

:: DesktopThumbnailControl class
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\DesktopThumbnailX.ocx
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\DesktopThumbnailX.ocx
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\DesktopThumbnailX61.ocx"
	del /q "C:\Windows\Downloaded Program Files\DesktopThumbnailX61.ocx"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\DesktopThumbnailX.ocx"
	del /q "C:\Windows\Downloaded Program Files\DesktopThumbnailX.ocx"

:: FileManagerX
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\FileManagerX.dll
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\FileManagerX.dll
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\FileManagerX61.dll"
	del /q "C:\Windows\Downloaded Program Files\FileManagerX61.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\FileManagerX.dll"
	del /q "C:\Windows\Downloaded Program Files\FileManagerX.dll"

:: KaseyaLiveConnectRelay class
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\LiveConnectRelayX.dll
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\LiveConnectRelayX.dll
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\LiveConnectRelayX61.dll"
	del /q "C:\Windows\Downloaded Program Files\LiveConnectRelayX61.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\LiveConnectRelayX.dll"
	del /q "C:\Windows\Downloaded Program Files\LiveConnectRelayX.dll"

:: RegistryEditor class
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\RegistryEditorX.dll
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\RegistryEditorX.dll
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\RegistryEditorX61.dll"
	del /q "C:\Windows\Downloaded Program Files\RegistryEditorX61.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\RegistryEditorX.dll"
	del /q "C:\Windows\Downloaded Program Files\RegistryEditorX.dll"

:: CmdLine class
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\CommandLineX.dll
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\CommandLineX.dll
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\CommandLineX61.dll"
	del /q "C:\Windows\Downloaded Program Files\CommandLineX61.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\CommandLineX.dll"
	del /q "C:\Windows\Downloaded Program Files\CommandLineX.dll"

:: TaskManager class
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\TaskManagerX.dll
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\TaskManagerX.dll
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\TaskManagerX61.dll"
	del /q "C:\Windows\Downloaded Program Files\TaskManagerX61.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\TaskManagerX.dll"
	del /q "C:\Windows\Downloaded Program Files\TaskManagerX.dll"

:: PluginManagerIE
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\PluginManagerIE.dll"
	del /q "C:\Windows\Downloaded Program Files\PluginManagerIE.dll"

:: EventLogging Class
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\EventLoggingX61.dll"
	del /q "C:\Windows\Downloaded Program Files\EventLoggingX61.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\EventLoggingX.dll"
	del /q "C:\Windows\Downloaded Program Files\EventLoggingX.dll"
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\EventLoggingX.dll
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\EventLoggingX.dll

:: CmdLine Class
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\CommandLineX61.dll"
	del /q "C:\Windows\Downloaded Program Files\CommandLineX61.dll"

:: MessageProtocol Class
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\MessageProtocolX61.dll"
	del /q "C:\Windows\Downloaded Program Files\MessageProtocolX61.dll"
	regsvr32 /u /s "C:\Windows\Downloaded Program Files\MessageProtocolX.dll"
	del /q "C:\Windows\Downloaded Program Files\MessageProtocolX.dll"
	regsvr32 /u /s C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\MessageProtocolX.dll
	del /q C:\Users\%Username%\AppData\Roaming\Kaseya\PluginManager\IE\MessageProtocolX.dll

Open in new window

Uninstalling all the plug-ins using this code has worked consistently in forcing the plug-ins to reinstall. The bug still exists in the LC software for IE however.
0
 
LVL 4

Accepted Solution

by:
Felicia King earned 0 total points
ID: 37844036
Kaseya's workaround was to use Firefox. I upgraded the K Server last week. Since then, the plugins are working again in I.E. Therefore, the problem this whole time was bug in their software. For others that were experiencing the same problem, upgrade your K Server using the full download. Applying hotfixes is not going to be big hammer enough.
0
 
LVL 4

Author Closing Comment

by:Felicia King
ID: 37859719
I have found the solution to this problem. Reinstallation of the plugins did not work on at least 8 computers on which it was tried. The problem was a bug in Kaseya software which has only been fixed very recently.
0

Featured Post

Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

Join & Write a Comment

Suggested Solutions

Several part series to implement Internet Explorer 11 Enterprise Mode
If you need to start windows update installation remotely or as a scheduled task you will find this very helpful.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now