?
Solved

How do I unblock ports on cisco 2801 router?

Posted on 2011-09-22
10
Medium Priority
?
851 Views
Last Modified: 2012-05-12
I'm having a problem with a polycom trying to dial to a remote location(the service center) from our office.

The service center has tried dialing this office through a video bridge many times from the there.  It rings here, but the Polycom will not pickup.  However when a call is initiated from here to the bridge at the service center it will connect.
They did a port scan from there to the private IP number, 10.26.1.5, which is NATed in my router(cisco 2801) to another IP number here (192.168.1.150).  The port scan  shows only a few ports open,  21,23,24,80,443,990,992,993,1720, and 5001.
According to Polycom the following ports need to be open for a successful video conference:
H.323 Ports (IP based video conferencing):
•      80 - Static TCP - HTTP Interface (optional)
•      389 - Static TCP - ILS Registration (LDAP)
•      1503 - Static TCP - T.120
•      1718 - Static UDP - Gatekeeper discovery (Must be bidirectional)
•      1719 - Static UDP - Gatekeeper RAS (Must be bidirectional)
•      1720 - Static TCP - H.323 call setup (Must be bidirectional)
•      1731 - Static TCP - Audio Call Control (Must be bidirectional)
•      1024-65535 Dynamic TCP H245
•      1024-65535 Dynamic UDP - RTP (Video data)
•      1024-65535 Dynamic UDP - RTP (Audio data)
•      1024-65535 Dynamic UDP RTCP (Control Information)
As you can see that means that just about every port in existence needs to be open.  The  fact that they are not is probably why the video call does not connect from the bridge.  It may be when this condition exists the Inbound ports are being blocked by a firewall or other device- maybe with an access list in a switch.But this is not the case here. The path is: Internet---cisco---switch---polycom.
In the meantime, a video call can connect if it is initiated from here to the service center. The question is how to open the ports up in the cisco 2801 router?

 
0
Comment
Question by:DLSEC
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
10 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 36580916
Post your current acl.
0
 

Author Comment

by:DLSEC
ID: 36581304
When I do
#show access-list, I get:
Standard IP access list 99
  10 permit 192.168.1.0, wildcard bits 0.0.0.255 (1484 matches)

I don't know much about this cisco router. can you tell me the specific command you want me to use?
Thanks.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36581490
do

sh ip access-list
0
Four New Appliances. Same Industry-leading Speeds.

But don't take it from us.  The Firebox M370 is Miercom tested and Miercom approved, outperforming its competitors for stateless and stateful traffic throughput scenarios.  Learn more about the M370, M470, M570 and M670 and find the right solution for your organization today!

 

Author Comment

by:DLSEC
ID: 36581735
OK, i did that and got the same thing:
#show access-list
Standard IP access list 99
  10 permit 192.168.1.0, wildcard bits 0.0.0.255 (1484 matches)
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36581766
Okay, just post your entire config. That can't possibly be the only ACL, at least I hope not.
0
 

Author Comment

by:DLSEC
ID: 36581845
!This is the running config of the router: 192.168.1.1
!----------------------------------------------------------------------------
!version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname DLSEC_2801
!
boot-start-marker
boot-end-marker
!
card type t1 0 2
logging buffered 8192 debugging
enable secret 5
!
no aaa new-model
no network-clock-participate wic 2
no network-clock-participate wic 3
ip cef
!
!
!
!
!
!
!
controller T1 0/2/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/2/1
 framing esf
 linecode b8zs
!
controller T1 0/3/0
 framing esf
 linecode b8zs
!
controller T1 0/3/1
 framing esf
 linecode b8zs
!
!
!
interface FastEthernet0/0
 description $ETH-LAN$
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 ip nat inside
 duplex auto
 speed auto
!
interface Serial0/2/0:0
 ip address 10.26.254.2 255.255.255.0
 ip nat outside
!
ip route 0.0.0.0 0.0.0.0 10.26.254.1
!
ip http server
ip nat pool NATP 10.26.1.10 10.26.1.254 netmask 255.255.255.0
ip nat inside source list 99 pool NATP
ip nat inside source static 192.168.1.216 10.26.1.2
ip nat inside source static 192.168.1.150 10.26.1.5
ip nat inside source static 192.168.1.3 10.26.1.6
ip nat inside source static 192.168.1.2 10.26.1.7
ip nat inside source static 192.168.1.9 10.26.1.8
!
access-list 99 permit 192.168.1.0 0.0.0.255
disable-eadi
!
control-plane
!
!
line con 0
 password 7
 login
line aux 0
line vty 0 4
 password 7
 login
!
scheduler allocate 20000 1000
end


0
 
LVL 26

Accepted Solution

by:
Soulja earned 2000 total points
ID: 36582124
If this is your current config on the router, then it can't be the source of the problem as it doesn't have any acl to prevent traffic flow.
0
 

Author Comment

by:DLSEC
ID: 36582449
Thanks for your help. Do you think the problem could be at the service center, because it looks like everything is good on this end?
Thanks again.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36582474
All I am saying is that it is not a port issue on your end because you don't have any acl's applied to your interfaces. I don't know what is inside your network. There could be ACL applied on L3 switches if you have them.
0
 

Author Closing Comment

by:DLSEC
ID: 36582490
Thank you.
0

Featured Post

Video: Liquid Web Managed WordPress Comparisons

If you run run a WordPress, you understand the potential headaches you may face when updating your plugins and themes. Do you choose to update on the fly and risk taking down your site; or do you set up a staging, keep it in sync with your live site and use that to test updates?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A 2007 NCSA Cyber Security survey revealed that a mere 4% of the population has a full understanding of firewalls. As business owner, you should be part of that 4% that has a full understanding.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question