Windows 7 Logon script not working

We are moving our network over to Windows 7 64 bit. The issue that we are having is that when we logon to the pc the AD logon scripts are not running. We can run them manually all day long. Also if after rebooting the machine and waiting awhile it will run fine. The issue that we seem to think it is, is that everytime we first logon the NIC goes into Identyfying network. Due to this it has no internet access and thus no network access to run the logon scripts. After about 30 seconds to a minute it identifies that nework and we have internet access and can manually launch the logon script. We would like to have these scripts run via AD and not GPO.. Any ideas would be greatly appreciated. Thanks.
tomtom98Asked:
Who is Participating?
 
McKnifeConnect With a Mentor Commented:
Hi.
Use this policy: http://technet.microsoft.com/en-us/library/cc780527(WS.10).aspx (same for seven) and activate it, do a gpupdate /force at the client (from an elevated command prompt) and restart for a test.
0
 
win7expertCommented:
Do you use a DHCP Server or static IP-Adresses?
0
 
tomtom98Author Commented:
DHCP
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
win7expertCommented:
Do you use an own DNS Server (within the Active Directory) or a DNS Server from ISP?
0
 
tomtom98Author Commented:
We have our own internal DNS servers.
0
 
tomtom98Author Commented:
unfortunatley working with the GPO is not an option right now as it is above our heads...any other ideas would be great till i can convience the higher ups to make this GPO change.
0
 
Jim-RCommented:
I had a similar issue, except it was a program running at start up.  Sometimes the timing was OK and it worked, but most of the time I had your situation.  Run it any time all day long and it started fine.  Delay logging in until HDD activity slowed down and it worked.

I simply used Task Scheduler to run the program and used the "Delay" feature set at 30 seconds to launch it and it's worked fine ever since.  This app also had that annoying UAC pop up, so checking off the "Run with highest privileges" took care of that little annoyance as well.
0
 
Jim-RCommented:
Forgot to mention using the "when user logs in" as the trigger for it, but you would have probably figured that out anyway because that is where you set the delay time.
0
 
McKnifeCommented:
You don't need to modify domain GPOs. Simply test it with a local GPO ->gpedit.msc This will do it as long as that policy is set to "not configured" at the domain GPOs. Change the local policy, do a gpupdate /force followed by rsop.msc to see if the new setting is active and reboot to start testing.
0
 
win7expertCommented:
But when you do this you have to change it on every machine manually.

You can try to deactivate your internal Network Adapter and reactivate it. Then it should ask you if you use a "Home", "Business" or "Public" Network. If you set this to Business Network, it shouldn't identifies the nework on every start.

 
0
All Courses

From novice to tech pro — start learning today.