Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 206
  • Last Modified:

exchange 2003 outbound mail broken

Outbound email to the internet is not working.  Ran smtpdiag and it returned no errors.  I suspect the internet SMTP connector is the issue.  I can telnet out on port 25 to external domains.  What should I do here?  Delete and recreate the SMTP connector?
0
AxISQS
Asked:
AxISQS
  • 5
  • 2
  • 2
1 Solution
 
AxISQSAuthor Commented:
To further explain, the email is going to sent items in Outlook, but not being delivered.  Inbound mail seems to be fine.  I followed this article:  http://www.msexchange.org/tutorials/exchange-server-2003-mailflow-part-2.html

The message tracker shows the message gets queued for remote delivery, but it doesn't seem to get delivered.
0
 
ctc1900Commented:
Do you see an error at the pane of the queue that's filling up with this e-mail?  
0
 
AxISQSAuthor Commented:
Dont see an error anywhere.  I dont see anything suspicisous in windows event viewer either.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
ctc1900Commented:
If you don't see any errors on the queue.  it should say:  "No additional information available." on the "Additional queue information" for the queue that is building up with this e-mails, correct?
0
 
AxISQSAuthor Commented:
I dont see that either.  It looks like each external site represents its own queue. example:

internet mail SMTP connector - site1.com
internet mail SMTP connector - site2.com

it goes on and on like that down the list, but there are no actual errors and I'm not seeing 'no additional information available'
0
 
Shreedhar EtteCommented:
- Disable the Antivirus application running on the exchange server and restart SMTP service.

- Does the mails are stuck on the queue?

- Also go to mxtoolbox.com and check the blacklisting of your public ip address.
0
 
AxISQSAuthor Commented:
@shreedhar

there is no antivirus running on this server.  All outbound mail is stopping in the queue.  I've restarted SMTP, IIS, and rebooted the server with no effect.  Mxtoolbox doesn't show our domain is blacklisted.
0
 
Shreedhar EtteCommented:
- On exchange server open the command prompt and execute the below command:
telnet alt1.gmail-smtp-in.l.google.com 25

- Please post what you get.

- Perform port scan of the public ip address at mxtoolbox.com
0
 
AxISQSAuthor Commented:
Found the problem for future users reference.  In our case, the DNS forwarders were no longer working.  For now, just using public DNS 4.2.2.2 as the forwarder fixed our problem.  I'll have to follow up with our ISP to verify the correct DNS servers.  Thanks
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 5
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now