Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 208
  • Last Modified:

exchange 2003 outbound mail broken

Outbound email to the internet is not working.  Ran smtpdiag and it returned no errors.  I suspect the internet SMTP connector is the issue.  I can telnet out on port 25 to external domains.  What should I do here?  Delete and recreate the SMTP connector?
0
AxISQS
Asked:
AxISQS
  • 5
  • 2
  • 2
1 Solution
 
AxISQSAuthor Commented:
To further explain, the email is going to sent items in Outlook, but not being delivered.  Inbound mail seems to be fine.  I followed this article:  http://www.msexchange.org/tutorials/exchange-server-2003-mailflow-part-2.html

The message tracker shows the message gets queued for remote delivery, but it doesn't seem to get delivered.
0
 
ctc1900Commented:
Do you see an error at the pane of the queue that's filling up with this e-mail?  
0
 
AxISQSAuthor Commented:
Dont see an error anywhere.  I dont see anything suspicisous in windows event viewer either.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
ctc1900Commented:
If you don't see any errors on the queue.  it should say:  "No additional information available." on the "Additional queue information" for the queue that is building up with this e-mails, correct?
0
 
AxISQSAuthor Commented:
I dont see that either.  It looks like each external site represents its own queue. example:

internet mail SMTP connector - site1.com
internet mail SMTP connector - site2.com

it goes on and on like that down the list, but there are no actual errors and I'm not seeing 'no additional information available'
0
 
Shreedhar EtteCommented:
- Disable the Antivirus application running on the exchange server and restart SMTP service.

- Does the mails are stuck on the queue?

- Also go to mxtoolbox.com and check the blacklisting of your public ip address.
0
 
AxISQSAuthor Commented:
@shreedhar

there is no antivirus running on this server.  All outbound mail is stopping in the queue.  I've restarted SMTP, IIS, and rebooted the server with no effect.  Mxtoolbox doesn't show our domain is blacklisted.
0
 
Shreedhar EtteCommented:
- On exchange server open the command prompt and execute the below command:
telnet alt1.gmail-smtp-in.l.google.com 25

- Please post what you get.

- Perform port scan of the public ip address at mxtoolbox.com
0
 
AxISQSAuthor Commented:
Found the problem for future users reference.  In our case, the DNS forwarders were no longer working.  For now, just using public DNS 4.2.2.2 as the forwarder fixed our problem.  I'll have to follow up with our ISP to verify the correct DNS servers.  Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 5
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now