Solved

connection problem to terminal server 2008 64 bit from ubuntu 10.10

Posted on 2011-09-22
8
318 Views
Last Modified: 2012-05-12
I have a windows 2008 64 bit server running terminal services, and I want to use some old machines with ubuntu 10.10 on them and want to use them running RDP onto the server 2008, in the same network and on the same subnet I can connect to a server 2008 32bit or any other RDP session even over a VPN connection, has anyone got any idea why this happens, do you think it is a licencing issue with the ubuntu machine, i did manage to connect once using rdpV5 but on the next occasion it just connected and then disconnected with in a second
0
Comment
Question by:philmc79
  • 4
  • 3
8 Comments
 

Expert Comment

by:nscoh
ID: 36583011
Possible things to look at:
Remote Desktop licensing configuration on the server.  If it is per machine licensing, make sure there are licenses available.  (note it is not concurrent machine licensing, meaning, if you have five licenses, the first five machines that connect to the server will take them for at least 60 days.)

Remote desktop licensing not configured and trial timeout period has expired.

The server compression may be too great for the client.  Try turning off terminal server compression:
Launch the Remote Desktop Session Host configuration
Right Click the RDP-Tcp and choose properties.
In the General Tab, change the Encryption level to Low
0
 

Author Comment

by:philmc79
ID: 36583429
We have 10 licences available and the licence model is per device but like i say we have 10 licences available, I have noticed the ubuntu machines in the temp licences issued, just for a bit more info, in the licence manager i have 13 licences in total but in 2 batches one of 3 licences and and one of 10 licences and the manager has allocated 3 of the licences to 3 windows machines but does not seem to be allocating any of the 10 to the 2 ubuntu machines, i have changed the encryption level to low, but it still starts the session then immediately disconnects, and like i say if i use windows RDP it works fine to the 2008 64 bit machine.
0
 
LVL 37

Expert Comment

by:Gerwin Jansen
ID: 36583784
Hi philmc79, are you allowing your ubuntu user to connect to your Windows server?

Add the user UBUNTU-SERVER\ubuntu-user to the Remote Deskop Users group.

Also, can you check at the RDP settings that you have "Allow connections from computers running any version of remote desktop (less secure)" instead of the more strict "Allow connections only from ...".
0
 

Author Comment

by:philmc79
ID: 36602474
I have checked all the above and yes to all of them, i think the problem is with the licence server, i have tried a RDP session with my Ipad and that works fine, so i think the problem is with the ubuntu RDP client, has anyone got any idea's, would it be an idea to add the ubuntu machine to the domain computers list
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 37

Expert Comment

by:Gerwin Jansen
ID: 36708428
Which RDP application are you using in Ubuntu?
0
 
LVL 37

Expert Comment

by:Gerwin Jansen
ID: 36708462
I tried with rdesktop to a W2003 server and W7 desktop, works just fine.
0
 

Accepted Solution

by:
philmc79 earned 0 total points
ID: 36943965
Found out the Problem it is all to do with the graphic's if you connect using full screen from the std RDP within Ubuntu it does not connect properly, if you run it in a window is works fine.

I found a nice little program that works in full screen mode called Remmina, thanks all you Guy's for your help but a lot of trawling the web and a bit of a little gem from someone problem gone away

0
 

Author Closing Comment

by:philmc79
ID: 36972712
I tried different solutions but could not get any of the help to work, had to work through it my self in the end
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Remote Desktop Connections allow you to control remote host machines via the magic of the Internet and RDP (Remote Desktop Protocol). For the purposes of this article we will assume you are connecting from your home PC or laptop to a remote offic…
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now