• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 546
  • Last Modified:

How do I increase the outbound mail attachment size in Exchange 2010


I have couple of questions on Exchange Server 2010:

1. How to increase the Outbound and Inbound mail attachment size for my users?

2. What is the Microsoft default and what is the recommendations for a small/mid size company?

  • 2
2 Solutions
There are actually several places to change these settings Byas. Each send and receive connector has a max message size, all of which default to 10 MB (10240 KB).

To change the outgoing message size limit open Exchange Managment console.  Expand the Organization Config group and click on Hub Transport.  To the right you should see a Hub Transport tab - click on that.
In this is your SMTP Send connector (I don't know the default name) - you can right cick and hit properties for each enabled item and Maximum Message Size should be on the first tab you open.  Unchecking thta box removes any limit, I believe.

To change the incoming message size you do the same thing except in Server Configuration instead of Organization Config.  Plus, it's the receive connector instead of the send or SMTP connector.
In Server Config -> hub Transport you'll see several connectors, you will want to change the limit for each for interoffice emails or however the server is moving the mail.
Byas_SahaAuthor Commented:
Dear "tganus". Thanks for your reply. I found this under "Global Settings tab". Now I have a question, after changing the size, when I am trying close the Exchange console window, it's giving me an error: "You must close all dialog boxes before you can close exchange management console"...any ideas why it's doing so when I know for sure there is no dialog box open.
Deepu ChowdaryCommented:
You can apply message size limits to individual messages that move through the Microsoft Exchange Server 2010 organization. You can restrict the total size of a message or the size of the individual components of a message, such as the message header, the message attachments, and the number of recipients. You can apply limits globally for the whole Exchange 2010 organization, or specifically for a particular connector or user object.

Follow these links


The error you are getting is actually a bizzare conflict between Internet Explorer 9 and the Exchange System Manager.  If you uninstall IE9 (go back to IE8 basically) then it will stop giving that error.  It doesn't hurt anything to force-kill the mmc.exe process in Taskmanager either.

Also Exchange9's links will be far more detailed and informative than my quick runthrough from memory could ever be, definitely check those out.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now