[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4949
  • Last Modified:

WMI "Failed to initialize all required WMI classes"

an online backup service I have uses WMI, which has a problem:

Failed to initialize all required classes.
Win32_Processor: Win32: cannot start a new logon session with an ID that is already in use.
Win32_WMISetting: successful
Security information: Successful
Win32_OperatingSystem: Win32: cannot start a new logon session with an ID that is already in use.

Server 03 SP2 fully patched. Was working fine until last Friday. Ran a WMIDiag from MS that generated a 5000k log file I can't make any sense out of.

Any ideas on how to fix this?
0
fnillc
Asked:
fnillc
  • 3
  • 2
1 Solution
 
Eduardo GoicovichIT ConsultantCommented:
check if KB979683  was installed

this breaks some wsf scripting
0
 
fnillcAuthor Commented:
KB979683 was installed on this machine on 7/20/2010, over a year ago. The problem started last week.
KB2570947 & KB2616676 were installed last week when the problem started, but these patches are also on other servers with the same backup process & they're working fine.
0
 
Eduardo GoicovichIT ConsultantCommented:
try rebuilding the repository

http://windowsxp.mvps.org/repairwmi.htm
0
 
fnillcAuthor Commented:
a simple reboot fixed it. Thanks for everyone's help.
0
 
fnillcAuthor Commented:
Rebooting the problem PC fixed the problem
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now