Solved

BizTalk Pipeline component duplicating backslash

Posted on 2011-09-22
2
288 Views
Last Modified: 2013-11-11
I have a pipeline component translating EDI to XML in the Disassemble stage.  I expect that if there is a backslash in the EDI that this backslash is copied to the output XML without change.  What I see is that a single backslash is translated to a pair of backslashes instead.

This is BT2006R2.  My pipeline is my custom disassembler followed by an XML Validator.

I have run the code in the disassembler outside the context of BizTalk in a test harnes, and I don't see the duplication.  Any ideas about where this duplication is happening?
0
Comment
Question by:skip_sailors
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
2 Comments
 

Author Comment

by:skip_sailors
ID: 36587841
I do not believe this to be a matter of seeing an escaped backslash in the debugger view of a text string.  I am sending the disassembled XML to a file and opening it in my text editor (UltraEdit or NotePad).  In the location where I expect to see a single character with a value 0x5C, I see two characters, 0x5C 0x5C.
0
 

Accepted Solution

by:
skip_sailors earned 0 total points
ID: 37022533
I found where I was inserting the character in my code. No mystery.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have put this article together as i needed to get all the information that might be available already into one general document that could be referenced once without searching the Internet for the different pieces. I have had a few issues where…
Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question