Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Cisco 877 router bridging with PPPoA

Posted on 2011-09-22
3
Medium Priority
?
594 Views
Last Modified: 2012-11-23
I was using the Cisco 877 router in bridge mode with PPPoE DSL. Now my ISP has been changed recently and now I am getting ADSL2 with PPPoA. Can you help me how I can configure the router so that it uses PPPoA with bridge mode.
Thanks
0
Comment
Question by:jamil0431
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 3

Accepted Solution

by:
woepwobin earned 500 total points
ID: 36585303
This is a snippet of what we used for bridged conncetions:
bridge irb
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0 0/35
  encapsulation aal5snap
  protocol ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto 
 bridge-group 1
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 hold-queue 100 out
!
interface BVI1
 ip address dhcp client-id Vlan1
 no ip redirects
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 BVI1 permanent
!
ip nat inside source list 101 interface BVI1 overload
!
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
bridge 1 protocol ieee
bridge 1 route ip

Open in new window

0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question